Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Здраствуйте, пожалуйста, помогите очень прошу поЗдраствуйте, пожалуйста, помогите по информатике составить програму по примеру:

10-11 класс

Programe...
var....:real
begin
write('....='):
readln(....):
формула и дальше
Задача.
Троим толстунам дали на десерт кремовые пирожные. Масса одного пирожные составляла х кг, а масса Толстяков в соответствии х1 кг, 2 кг, х3 кг. Первый Толстяк съел n пирожных. Каждый следующий Толстяк съедал в два раза больше предыдущего, но при этом все они не могли съесть больше, чем половина их собственной массы. Сколько пирожных съели Толстяка?

Максим777 24 мая 2013 г., 7:44:08 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Runof
24 мая 2013 г., 9:52:14 (10 лет назад)

Program FatBoys;
Var x, x1, x2, x3: Real;
n, n2, n3, i: Integer;
Begin
Write('x = ');
ReadLn(x);
Write('x1 = ');
ReadLn(x1);
Write('x2 = ');
ReadLn(x2);
Write('x3 = ');
ReadLn(x3);
Write('n = ');
ReadLn(n);
If x * n > x1 / 2 Then
WriteLn('Первый толстяк не смог бы съесть столько пирожных')
Else
Begin
For i := 1 To 2 * n Do
Begin
If (n2 * x + 1) <= x2 / 2 Then
n2 := n2 + 1
Else
Break;
End;
For i := 1 To 2 * n2 Do
Begin
If (n3 * x + 1) <= x3 / 2 Then
n3 := n3 + 1
Else
Break;
End;
WriteLn('Вместе толстяки съели ', n + n2 + n3, ' пирожных');
End;
ReadLn;
End.

+ 0 -
Ansvet122
24 мая 2013 г., 10:26:15 (10 лет назад)

Комментарий удален

+ 0 -
Violetta666
24 мая 2013 г., 11:42:38 (10 лет назад)

можете кинуть фотографию условия?

+ 0 -
Nastysha2001366
24 мая 2013 г., 13:51:08 (10 лет назад)

Комментарий удален

+ 0 -
Gelyafilippova
24 мая 2013 г., 16:45:35 (10 лет назад)

Розумієш, в чому тут справа: одна умова перечить іншій. Кожен наступний зїдав в 2 рази більше попередньго але не більше ніж половина його ваги? Тобто якщо наїв половину, то відкинути умову, що він мав зїсти в 2 рази більше попереднього?

+ 0 -
Teenwolf823
24 мая 2013 г., 19:37:16 (10 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

помогите с решением 1)Модем передаёт информацию со скоростью 29 к бит/с Надо предать 3 документа Обьём

документов

1)380000 байт

2)5листов по 100 символов (16бит код)

3)0.75мбайт

2)Определите информационный объем растрового изображения размером

1024х768 пикселей и состоящее из 64 цветов

Написать программу, которая

записывает в файл все слова, начинающиеся с задаваемой с клавиатуры буквы из
исходного текстового файла. Словом считать набор символов, не содержащий
пробелов, знаков препинания и ограниченный пробелами, знаками препинания или
началом/концом строки. Если исходный файл не содержит подходящих слов, то
оставить результирующий файл пустым.

Программа в Turbo Pascal

Записать в файл N латинских
символов. Выполнить
следующие операции с созданным файлом:

Читайте также

Используя функцию нахождения минимума двух чисел, составьте программу ,

которая из трех введенных цифр составляет наименьшее трехзначное число.
Пожалуйста помогите, очень прошу


Пожалуйста СРОЧНО Помогите с домашним заданием по Информатике... Заранее Очень Очень Сильно Благодарен за Ваши Ответы :)

1. Логическое выражение называется тождественно-ложным, если оно принимает значения 0 на всех наборах входящих в него простых высказываний. Упростите следующее выражение и покажите, что оно тождественно-ложное.

_ _ _

(A&B&B) v (A&A) v (B&C&C).

2. Упростите логические выражения. Правильность упрощения проверьте с помощью таблиц истинности для исходных и полученных логических формул.

_

а) A v (A&B) ;

_ _

б) (A v B)&( B v A)&(C v B) .

Решить любую из двух задач. Если две - то спасибо :)

1) В одномерном массиве встречаются нули. Согнать их всех в одну сторону.(задача на пузырьковый метод)
2) После ввода одномерного массива:
-сначало идут положительные по возрастанию

-потом все нули

-потом все отрицательные чила по возрастанию

Пример:-1 5 -7 0 3 0 -2 6 8

вывод: 3 5 6 8 0 0 -7 -2 -1

Помогите, очень прошу вас.



Вы находитесь на странице вопроса "Здраствуйте, пожалуйста, помогите очень прошу поЗдраствуйте, пожалуйста, помогите по информатике составить програму по примеру:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.