Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Программа в Turbo Pascal

10-11 класс

Записать в файл N латинских
символов. Выполнить
следующие операции с созданным файлом:

Рилитая 31 марта 2017 г., 14:58:37 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ирина2453332
31 марта 2017 г., 16:48:57 (7 лет назад)

var
  s: string;
  f1, f2: Text;
  i, k, N: integer;

begin
  writeln('Введите количество символов N');
  readln(N);
  writeln('Вводите символы:');
  readln(s);
  s := Copy(s, 1, N); // Если ввели больше N - обрезать
  writeln('Исходная строка: ', s);
  Assign(f1, 'f1.dat');
  Rewrite(f1);
  write(f1, s);  // запись в файл исходноц строки
  Close(f1);
  Reset(f1);    // повторно открываем файл на чтение
  Read(f1, s);
  for i := 1 to length(s) do
    if s[i] = 'p' then s[i] := 'w';
  Writeln('Замена w->p: ', s);
  Assign(f2, 'f2.dat');
  Rewrite(f2);
  Write(f2, s);
  Close(f2);
  Reset(f1);
  Read(f1, s); // Снова читаем в s файл f1
  Assign(f2, 'h.dat');
  Rewrite(f2);
  for i := 1 to length(s) do
    if Pos(s[i], 'aeiouy') > 0 then
      write(f2, s[i]);
  Close(f2);
  Reset(f2);
  Read(f2, s);
  writeln('Гласные из исходного файла: ', s);
  Close(f2);
  Close(f1);
  Assign(f2, 'f2.dat');
  Reset(f2);
  Read(f2, s);
  Close(f2);
  k := 0;
  for i := 1 to length(s) do
    if s[i] = 'f' then k := k + 1;
  writeln('Количество букв f= ', k)
end.

Тестовый пример:

Введите количество символов N
40
Вводите символы:
the quick brown fox jumpes over lazy dog *****
Исходная строка: the quick brown fox jumpes over lazy dog
Замена w->p: the quick brown fox jumwes over lazy dog
Гласные из исходного файла: euiooueoeayo
Количество букв f= 1



Ответить

Другие вопросы из категории

Помогите,пожалуйста

2.написать примеры оператора вывода данных и работу ЭВМ с этим оператором

Для кодирования цвета фона интернет-страницы используется атрибут bgcolor="#ХХХХХХ", где в кавычках задаются шестнадцатеричные значения

интенсивности цветовых компонент в 24-битной RGB-модели следующим образом:

Читайте также

Написать программу на turbo pascal.

1.Вычислить значение факториала n! (P=1*2*...*n*N)..N=12
2.Найти сумму элементов заданного массива C[1..n]. Данные для ввода: n=7; C[1;2;3;-4;5;-6;7].
3.

Написать программу проверки знания истории архитектуры. Программа должна вывести вопроси три варианта ответа. Пользователь должен выбрать

правильный ответ и ввести его номер.Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом).
Архитектор Исаакиевского собора:
1. Доменико Трезини
2. Огюст Монферран
3. Карл Росси
Введите номер правильного ответа и нажмите <Enter>
= 2
Правильно.
Архитектор Исаакиевского собора - Огюст Монферран

на языке Turbo Pascal



Вы находитесь на странице вопроса "Программа в Turbo Pascal", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.