Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите, пожалуйста, срочно

10-11 класс

Нужно написать программу в паскале
Найти наименьшее общее кратное n натуральных чисел, используя алгоритм евклида.

Агент012 28 мая 2013 г., 12:17:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Diana4593
28 мая 2013 г., 14:42:00 (10 лет назад)

var i, a, b, t, d, n : integer;
x : array of integer;
begin
    read(n);
    SetLength(x, n + 1);
    for i := 1 to n do
        read(x[i]);
    a := x[1];
    for i := 2 to n do begin
        b := x[i];
        d := a * b;
        while (b > 0) do begin
            t := a;
            a := b;
            b := t mod b;
        end;
        a := d div a;
    end;
    writeln(a);
end.

Ответить

Другие вопросы из категории

Здраствуйте, пожалуйста, помогите очень прошу поЗдраствуйте, пожалуйста, помогите по информатике составить програму по примеру:

Programe...
var....:real
begin
write('....='):
readln(....):
формула и дальше
Задача.
Троим толстунам дали на десерт кремовые пирожные. Масса одного пирожные составляла х кг, а масса Толстяков в соответствии х1 кг, 2 кг, х3 кг. Первый Толстяк съел n пирожных. Каждый следующий Толстяк съедал в два раза больше предыдущего, но при этом все они не могли съесть больше, чем половина их собственной массы. Сколько пирожных съели Толстяка?

помогите с решением 1)Модем передаёт информацию со скоростью 29 к бит/с Надо предать 3 документа Обьём

документов

1)380000 байт

2)5листов по 100 символов (16бит код)

3)0.75мбайт

2)Определите информационный объем растрового изображения размером

1024х768 пикселей и состоящее из 64 цветов

Написать программу, которая

записывает в файл все слова, начинающиеся с задаваемой с клавиатуры буквы из
исходного текстового файла. Словом считать набор символов, не содержащий
пробелов, знаков препинания и ограниченный пробелами, знаками препинания или
началом/концом строки. Если исходный файл не содержит подходящих слов, то
оставить результирующий файл пустым.

Читайте также

Помогите пожалуйста!) Напечатать программу в паскале......

Пожалуйста...Срочно...Завтра крайний срок сдачи...Помогите...

Дан массив строк без пробелов. Напечатать строки, вторая половина которых не содержит цифры.

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!



Вы находитесь на странице вопроса "Помогите, пожалуйста, срочно", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.