Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

помогите пожалуйста! составить программу вычисляющую сторону ромба если известны 2 диагонали?

10-11 класс

Ybershadskaya 09 авг. 2014 г., 15:24:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akor5178
09 авг. 2014 г., 16:59:25 (9 лет назад)

Program P1;
Uses Crt;
Var a, b, c : Real;

Begin
ClrScr;
Write('Введи 2 диагонали через пробел: ');
Readln(a, b);
c := sqrt(sqr(a / 2) + sqr(b / 2));
Write('Сторона ромба = ', c : 0 : 5);

Readln;
End.

Ответить

Другие вопросы из категории

10. Составьте

программу, которая вводит
с клавиатуры три
целых числа: a, b, c (каждое
число с новой
строки) и выводит
на экран максимальное
из них. Ничего
кроме этого числа,
программа выводить не
должна.

посчитать сумму элементов от 1 до 5
нарисуйте блок схему по листингу задачи.Даша Пупырышкина изучает английский язык во втором классе. Ей задали домашнее задание: переписать

английские слова, записанные строчными буквами, в тетрадь. Выполняя задание, она комментирует его. Даша произносит слово "Опять" каждый раз, когда пишет букву, которая уже встречалась в слове раньше.
Составьте программу, которая по слову определяет: сколько раз Даша произнесёт "Опять".
Примеры:
Исходное слово apple Ответ 1 раз
Исходное слово potato Ответ 2 раза
Ваша программа должна
Запросить слово;
Подсчитать сколько раз, переписывая это слово, Даша произнесёт "Опять" и вывести это число на экран.



program dasha;
var s: string;
x, l, i, y, j: byte;
begin
writeln('введите слово');
readln(s);
l := length(s);
y := 0;
for i:=1 to 1-1 do
for j:=i+1 to l do
if (s[i] = s[j]) then y := y+1;
writeln('Даша скажет опять', y, ' раз');
end.

Читайте также

Здравствуйте, уважаемые :) Помогите пожалуйста составить программу на Паскале. Спасибо огромное!

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду щего элемента;
3-й-равен сумме двух предыдущих элементов.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет
Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".



Вы находитесь на странице вопроса "помогите пожалуйста! составить программу вычисляющую сторону ромба если известны 2 диагонали?", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.