Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

составить программу и записать на одном из языков программирования . с клавиатуры вводятся три числа A,B,C . если А четное отрицательное число,то

5-9 класс

вывести на экран значение суммы чисел A,B,C ,иначе значение произведения.

AlinochkaBlinova1 02 февр. 2015 г., 8:38:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anya291197
02 февр. 2015 г., 11:37:50 (9 лет назад)

var a, b, c: integer;

begin

  readln(a, b, c);

  if (a<0)and(a mod 2=0) then writeln(a+b+c)

  else writeln(a*b*c);

end.

Ответить

Другие вопросы из категории

Внесите недостающие надписи в схему.

признаки объектов, дано 4 пустых графы, помогите!!!

почему в ответе получается 26? var s,i:integer;

mas:array[1..10] of integer;
begin
mas[1]:=14;
mas[2]:=10;
mas[3]:=-8;
mas[4]:=6 ;
mas[5]:=12;
mas[6]:=4 ;
mas[7]:=-16 ;
mas[8]:=-7 ;
mas[9]:=5;
mas[10]:=3;
s:=0;
for i:=1 to 5 do
mas[2*i]:=0;
for i:=1 to 10 do
if mas[i]>5 then s:=s+mas[i];
write(s);
end.

Читайте также

. Дан массив, содержащий 2014 положительных целых чисел. Напишите на одном из языков программирования программу, которая находит в этом массиве количество

элементов, значение которых более чем в два раза превосходит значение предшествующего элемента. Например, для массива из 6 элементов, содержащего числа 2, 5, 10, 15, 40, 100, программа должна выдать ответ 3 (условию соответствуют элементы со значениями 5, 40 и 100). Программа должна вывести общее количество подходящих элементов, значения элементов выводить не нужно. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из описанных переменных.
Паскаль Алгоритмический язык
const N = 2014;
var a: array [1..N] of integer;
i, j, k: integer;
begin
for i:=1 to N do
readln(a[i]);

end. алг
нач
цел N=2014
целтаб a[1:N]
цел i, j, k
нц для i от 1 до N
ввод a[i]
кц

кон


Дан целочисленный массив из 30 элементов. Элементы могут принимать значения от 0 до 100 – баллы, полученные на ЕГЭ. Опишите на русском языке или

на одном из языков программирования алгоритм, который подсчитывает и выводит средний балл учащихся, сдавших экзамен (получивших оценку более 20 баллов). Гарантируется, что хотя бы один ученик в классе успешно сдал экзамен.

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.




Вы находитесь на странице вопроса "составить программу и записать на одном из языков программирования . с клавиатуры вводятся три числа A,B,C . если А четное отрицательное число,то", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.