Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Всем привет.Мой вопрос заключается в задаче на массив. На промежутке от A и B подсчитайте количество четных чисел.

5-9 класс

g>Заранее спасибо!!!!!

Maestro25032004 01 окт. 2013 г., 4:12:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Siliz620231
01 окт. 2013 г., 6:54:50 (10 лет назад)

program nfcdjcfi;

uses crt;

var e:array [1..100] of integer;

       i,a,b,kolvo:integer;

begin

clrscr;

kolvo:=0;

readln(a,b);

for i:=a to b do

if e[i] mod 2 =0 then kolve:=kolvo+1;

writeln(kolvo);

readln;

end.

Ответить

Читайте также

решите пожалуйста задачи на языке pascal abc net.

f3.
Дано целое число. Если оно является положительным, то прибавить к нему 1; если отрицательным, то вычесть из него 2; если нулевым, то заменить его на 10. Вывести полученное число.
f5.
Даны три целых числа. Найти количество положительных и количество
отрицательных чисел в исходном наборе.
f15.
Даны три числа. Найти сумму двух наибольших из них.

Ребята,нужно в паскале решить задачи на массив.

1) в массиве 50 элементов. Определить количество чисел больше,равны и меньше нуля.
2) в массиве 20 элементов. Опеределить количество чисел,у которых:
Цифра десятков кратна 2(или просто само число кратно 2) и число больше нуля.
Решение по типу этой задачи. Числа вводятся по запуску программы.

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!

1)Напишите программу, которая в последовательности натуральных чисел определяет количество всех чисел, кратных 3 и оканчивающихся на 4. Программа получает

на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность).

2)Найти среднее арифметическое всех целых чисел от a до 200 (значения a и b вводятся с клавиатуры; a>=200);



Вы находитесь на странице вопроса "Всем привет.Мой вопрос заключается в задаче на массив. На промежутке от A и B подсчитайте количество четных чисел.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.