Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны целые числа a, b, c. Если a ≤ b ≤ c, то все числа заменить rкубами, если a>b>c, то смените знак каждого числа, в противном случае каждое

5-9 класс

число заменить наибольшим и них.

Karinka2345 08 февр. 2015 г., 1:55:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Emelyanalaz
08 февр. 2015 г., 4:43:34 (9 лет назад)

program chisla;
var a,b,c:real;
begin
write('Введите числа a,b и с через пробел:'); readln(a,b,c);
if (a<=b) and (b<=c) then begin
a:=exp(ln(a)*3);
b:=exp(ln(b)*3);
c:=exp(ln(c)*3);
end;
if (a>b) and (b>c) then begin
a:=-a;
b:=-b;
c:=-c;
end;
writeln(a,' ',b,' ',c);
end.
;)

Ответить

Другие вопросы из категории

Читайте также

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Составить программы в Turbo Pascal. 1)Дано три точки A,B,C на числовой оси.Найти длинну отрезка AC и BC и их сумму. 2)Задано четыре целых числа

a,b,c,d.Выяснить произведение этих чисел больше 300? 3)Дано целое число ,если оно положительное,то прибавить к нему 1,а если отрицательное.то отнять от него 2.Вывести полученое число.

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.



Вы находитесь на странице вопроса "Даны целые числа a, b, c. Если a ≤ b ≤ c, то все числа заменить rкубами, если a&gt;b&gt;c, то смените знак каждого числа, в противном случае каждое", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.