Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задается последовательность целых чисел. Сколько чисел отличается от первого на 1 ?Написать программу на паскале без использования массивов

10-11 класс

Jasminka996 20 апр. 2013 г., 6:52:08 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lada112002
20 апр. 2013 г., 9:20:24 (11 лет назад)

uses crt;
var n, a, b, k:integer;
begin     k:=0;     
writeln ('Сколько цифр будет в строке?');     
read (n);     
writeln ('Вводите числа, после каждого ENTER.');     
read (b);     
for n:=1 to n-1 do     
begin     
read (a);     
if a+1=b then k:=k+1 else     
if a-1=b then k:=k+1;     
end;     
writeln ('Количество чисел отстающих на 1 от первого числа - ',k);
end.

Ответить

Другие вопросы из категории

написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,

которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от
того, лежит ли точка внутри заштрихованной области, вне заштрихованной области
или на ее границе.

паскаль

Найти все натуральные
решения уравнения:x^3+y^3=M . Где М>0 задает
пользователь. Использовать вложенные циклы.

Читайте также

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

Помогите написать программу в паскале!Очень надо!

Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

Даны натуральное число n и последовательность целых чисел а1, а2,…,аn.. Определить количество тех членов последовательности, которые нечетны . Найти

сумму членов последовательности, кратных 11. Составить блок-схему алгоритма, написать программу.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.



Вы находитесь на странице вопроса "Задается последовательность целых чисел. Сколько чисел отличается от первого на 1 ?Написать программу на паскале без использования массивов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.