Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

вычислить массу всех учеников 10 класса,в классе 7 человек

10-11 класс

Annabragida 17 июня 2013 г., 9:59:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
НАСТ2100
17 июня 2013 г., 10:38:56 (10 лет назад)

Если мы сразу присваиваем значение массы, пишем:

For i:=1 to n do

 begin

 a[i]:=random(30);

a[i]:=a[i]+45;

end;

Таким образом мы присвоили элементам массива значения от 45 до 75.

Если нужно высчитать по формуле:

Я беру формулу Масса=Рост-100.

Тогда

For i:=1 to n do

 begin

 a[i]:=random(30);

a[i]:=a[i]+150;

end;

For i:=1 to n do

 write((a[i]-100):3);

 

где a[i] - рост, n - количество учеников. Рост задаётся в диапазоне от 150 до 180. Изменить формулу массы можно в строчке  write((a[i]-100):3);

 

Ответить

Другие вопросы из категории

Написать программу проверки знания даты начала второй мировой войны. В случае неверного ответа пользователя программа должна выводить правильный ответ.

Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные пользователем, выделены полужирным шрифтом). В каком году началась вторая мировая война? Введите число и нажмите <Enter>

написать программу на языке с#:Дана точка на плоскости с координатами (х, у). Составить программу,

которая выдает одно из сообщений «Да», «Нет», «На границе» в зависимости от
того, лежит ли точка внутри заштрихованной области, вне заштрихованной области
или на ее границе.

Читайте также

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835

25 баллов инфа?

Муниципальный этап олимпиады по информатике проводился для учеников
7–11-х классов. Все ученики участвовали в общем конкурсе. Каждый
участник олимпиады мог набрать от 0 до 400 баллов. По положению об
олимпиаде победителем признаётся участник, набравший наибольшее
количество баллов, при условии, что им набрано больше половины
возможных баллов. Победителей может быть несколько, если это количество
баллов наберут несколько человек; а может и не быть совсем, если никто не
наберёт больше половины.
Напишите эффективную по времени работы и по используемой памяти
программу (укажите используемую версию языка программирования,
например Borland Pascal 7.0), которая будет определять фамилию и имя
лучшего участника, не ставшего победителем олимпиады. Если следующий
за баллом победителей один и тот же балл набрали несколько человек или
если победителей нет, а лучших участников несколько (в этом случае они же
являются искомыми), то должно выдаваться только число искомых
участников. Гарантируется, что искомые участники (участник) имеются.
На вход программе сначала подаётся число участников олимпиады N
(N<10000).
В каждой из следующих N строк находится результат одного из участников
олимпиады в следующем формате:
<Фамилия> <Имя> <класс> <баллы>,
где <Фамилия> – строка, состоящая не более чем из 20 непробельных
символов; <Имя> – строка, состоящая не более чем из 15 непробельных
символов; <класс> – число от 7 до 11; <баллы> – целое число от 0 до 400
набранных участником баллов. <Фамилия> и <Имя>, <Имя> и <класс>,
а также <класс> и <баллы> разделены одним пробелом. Пример входной
строки:
Иванов Пётр 10 275
Программа должна выводить через пробел Фамилию и Имя искомого
участника или их число. Пример выходных данных:
Кузнецов Иван
Второй вариант выходных данных:
4



Вы находитесь на странице вопроса "вычислить массу всех учеников 10 класса,в классе 7 человек", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.