Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Сумма M первых чисел, которые образуют последовательность

10-11 класс

Фибоначчи по следующему правилу: F

Simonova2332 26 окт. 2013 г., 3:48:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
10251986
26 окт. 2013 г., 6:11:03 (10 лет назад)

var f1,f2,f,m,s:integer;
begin
f1:=1;
f2:=1;
s:=2;
m:=2;
while s<102334154 do
  begin
  m:=m+1;
  f:=f1+f2;
  s:=s+f;
  f1:=f2;
  f2:=f;
  end;
writeln('M=',m);
end.

М=38

Ответить

Другие вопросы из категории

Сообщение на русском языке закодировано 2-байтным кодом Unicode и имеет длину 1025024 символа. На сколько килобайт уменьшится длина этого сообщения после

его перекодировки в 8-битный код КОИ-8R.
Вот в ответе указано 11. у меня же получается 1001. Думаю о возможной опечатке.

Шалтай- Болтай.

Сидел на стене.
Шалтай -Болтай
Свалился во сне.
Вся королевская конница,
Вся королевская рать
Не может
Шалтая,
Не может
Болтая,
Шалтая-Болтая,
Болтая-Шалтая,
Шалтая-Болтая собрать!
ответите:в тексте ровно сколько знаков препинания,сколько дефисов и сколько апострофов.

Читайте также

Сумма M первых чисел, которые образуют последовательность Фибоначчи

по следующему правилу: F1 = 1, F2 = 1, Fn

Сумма M первых чисел, которые образуют последовательность

Фибоначчи по следующему правилу: F1 = 1, F2 = 1, Fn

Сумма

M первых чисел,
которые образуют последовательность Фибоначчи по следующему правилу: F1 =
1, F2 = 1, Fn+1 = Fn+Fn-1
для n>1 равна 102334154. Найдите число M

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.



Вы находитесь на странице вопроса "Сумма M первых чисел, которые образуют последовательность", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.