Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Сумма M первых чисел, которые образуют последовательность Фибоначчи

10-11 класс

по следующему правилу: F1 = 1, F2 = 1, Fn

Fajagul 17 апр. 2015 г., 8:20:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BugsBunny23
17 апр. 2015 г., 10:12:26 (9 лет назад)

M будет равно 38
Вот код программы на С# и картинку с результатом работы программы сразу прилаживаю ) в принципе алгоритм не очень сложный)
 int a = 1, b = 1, c = 2, d = 0; int M = 2;  
 do
{
  d = (b + a);       
  a = b;             
 b = d;              
  c += d;              
  M++;
    Console.WriteLine(c);            }          
  while (c != 102334154);            
Console.WriteLine("---------------------------");           
 Console.WriteLine("M = " + M);           
 Console.ReadLine();

+ 0 -
Danial200002
17 апр. 2015 г., 11:14:32 (9 лет назад)

а кто что знает?

+ 0 -
Angelinochaaaa
17 апр. 2015 г., 12:18:20 (9 лет назад)

давайте вместе

+ 0 -
Narinabass
17 апр. 2015 г., 14:37:09 (9 лет назад)

что ты знаешь?

+ 0 -
Aannsyper
17 апр. 2015 г., 15:44:41 (9 лет назад)

У меня тоже она)

+ 0 -
Olya461
17 апр. 2015 г., 18:29:23 (9 лет назад)

я знаю) 38 будет)

Ответить

Другие вопросы из категории

На координатной плоскости своими действительными координатами (x1, y1), (x2, y2), (x3, y3), (x4, y4) задан выпуклый четырехугольник. Проверить, является

ли он параллелограммом, если ДА – вычислите выражение |(a+b)2+| с точностью до сотых, где а и b смежные стороны параллелограмма.

помогите срочно))

что сможете))
нужно решить в течении получаса_))

помогите создать таблицу в html
ПОМОГИТЕ СРОЧНО ПЖЛСТ!!!

Автоматизированная система управления кадрами предприятия хранит личные дела работников в следующем формате: каждое личное дело
содержит 12 страниц, по 36 строк на каждой странице, по 64 символа в каждой строке, каждый символ кодируется одним байтом. Определите количество личных дел, хранимых в автоматизированной системе, если известно, что все данные занимают в памяти компьютера 13,5 мегабайта.

Читайте также

Сумма

M первых чисел,
которые образуют последовательность Фибоначчи по следующему правилу: F1 =
1, F2 = 1, Fn+1 = Fn+Fn-1
для n>1 равна 102334154. Найдите число M

Сумма M первых чисел, которые образуют последовательность

Фибоначчи по следующему правилу: F1 = 1, F2 = 1, Fn

Сумма M первых чисел, которые образуют последовательность

Фибоначчи по следующему правилу: F

Написать программу в Паскале. Последовательность фибоначчи образуется так:первый и второй члены равны 1,каждый следующий равен сумме двух

предыдущих(1,1,2,3,5,8,13,...)найти числа последовательности фибоначчи сумма которых меньше пятизначного числа n.

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.



Вы находитесь на странице вопроса "Сумма M первых чисел, которые образуют последовательность Фибоначчи", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.