Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вывести на экран числа от a до b,если a>b ( через оператор For и через оператор While)

5-9 класс

Daymohk 22 марта 2014 г., 14:56:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
37lison
22 марта 2014 г., 15:57:12 (10 лет назад)

var a,b,k:integer;
begin
read(a,b); k:=a-1;
if a>b then do 
while k<>b do begin
write(k); k:=k-1;
end;
end.

+ 0 -
Mariurkoz
22 марта 2014 г., 18:13:52 (10 лет назад)

может все же "или", а не "и"

+ 0 -
ДевчоночкАА
22 марта 2014 г., 19:48:09 (10 лет назад)

неправильно напечатано условие

+ 0 -
Albina7muse
22 марта 2014 г., 21:20:21 (10 лет назад)

и через For мне надо,и через While,две программы

+ 0 -
Vladsvs11
22 марта 2014 г., 23:07:05 (10 лет назад)

Veter0k, ну и что в условии неправильно?

Ответить

Другие вопросы из категории

Помогите с написанием программ в Помогите с написанием программ в ПАСКАЛЕ

1) Если а>7, то найти сумму BC, иначе найти разность.

2) Определить квадрат числа, если оно положительное, но если отрицательное - куб.

3) Идет К-ая секунда суток. Напечатать сколько полных часов, минут и секунд прошло к данному моменту.

4) В магазине продается костюмная ткань. Ее цена В рублей за квадратный метр. Напишите программу, которая подсчитает и выведет на экран стоимость куска этой ткани, длиной Х метров и шириной 80 см.

Задача Даны две переменные A и B. Требуется поменять местами их значения, т.е. переменная A должна получить значение B, а B — значение A

trong>.
Переведите на язык программирования Pascal, блок-схему решения данной задачи.

Читайте также

Задание 4.Составте программу ,выводящую на экран числа от 1 до 10 , по одному числу в строке.

Задание 5.Дополните программу из задания 4 так , чтобы на экран выводились числа от 1 до 10,а также квадраты и кубы этих чисел в следующем виде:
1 1 1
2 4 8
3 9 27
... ... ...
10 100 1000

ПОМОГИТЕ ПОЖАЛУЙСТА,ЗАДАНИЕ 4 ПИСАТЬ НЕ НУЖНО !ПОСТАВЛЮ ЛУЧЩИЙ ОТВЕТ И "СПАСИБО"

выведите на экран числа от 100 до 200

вывести на экран квадраты и кубы в диапазоне от -10 до +10
используя repeat

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале

Напишите следующую программу. Введите с клавиатуры целое число N. Выведите на экран числа от 1 до N так, чтобы каждое число выводилось столько раз, каково

его значение. Например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6
Написать программу нужно как можно проще в программе PascalABC



Вы находитесь на странице вопроса "Вывести на экран числа от a до b,если a&gt;b ( через оператор For и через оператор While)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.