Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составте програм которая заполняет массив а[1...10] случайными целыми числами в диапозоне от 1 до 10 и находит количество элементов ,которые больше своего

5-9 класс

соседа слева

Madja 23 сент. 2014 г., 10:20:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mrnakuna
23 сент. 2014 г., 12:39:53 (9 лет назад)

var a:array[1..10]of integer;
     i,k:integer;
begin
 write('massiv');
 for i:=1 to 10 do
  begin
   a[i]:=random(10)+1;
   write(a[i],' ');
  end;
 writeln;
 for i:=1 to 9 do
  if a[i]<a[i+1] then k:=k+1;
 write('kol-vo:',k);
end.

Ответить

Другие вопросы из категории

В некотором каталоге хранился файл Хризантема.doc, имевший

полное имя D:\2013\Осень\Хризантема.doc. В этом каталоге создали
подкаталог Ноябрь и файл Хризантема.doc переместили в созданный
подкаталог. Укажите полное имя этого файла после перемещения.

Плз помогите:

Дано:
N=64 симв.
K=x*30*6
I=8775
Найти:x(кол-во символов в одной строке

В финале турнира Российской армии по шахматам встретились представители шести воинских званий: майор, капитан, лейтенант, старшина, сержант и еф­рейтор,

разных специальностей: летчик, танкист, ар­тиллерист, минометчик, сапер и связист. Определите специальность и звание каждого из шахматистов по следующим данным:

1) в первом туре лейтенант выиграл у летчика, майор — у танкиста, а сержант — у минометчика;

2) во втором туре капитан выиграл у танкиста;

3) в третьем и четвертом турах минометчик из-за бо­лезни не участвовал в турнире, поэтому свободными от игры оказались капитан и ефрейтор;

4) в четвертом туре майор выиграл у связиста;

5) победителями турнира оказались лейтенант и майор, а хуже всех выступил сапер.

Читайте также

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

1)Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все

элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все элементы с нечётными значениями в три раза,а элементы с чётными значениями заменяя на 0.

A) Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями

и количество элементов с нечетными значениями.

б) Составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количество элементов с четными значениями.



Вы находитесь на странице вопроса "составте програм которая заполняет массив а[1...10] случайными целыми числами в диапозоне от 1 до 10 и находит количество элементов ,которые больше своего", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.