Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1.Построить файл данных, компонентами которого являются натуральные числа. Подсчитать сумму тех компонент, которые делятся на 5 и не делятся на 10.

10-11 класс

2.Построить типизированный файл данных, который состоит из записей с такими полями: название продукта, количество углеводов, количество белков, количество жиров. Вывести названия тех продуктов, которые соответствуют следующим условиям: белки меньше 20, жиры больше 10, углеводы больше 30.

Джульетик 21 марта 2016 г., 12:00:23 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Shevelevsn
21 марта 2016 г., 12:54:28 (8 лет назад)


Program KDSUP_1;
uses crt;
Var
  f: File of Integer;
  i,n,x,sum : Integer;
begin
  write('Введите количество чисел: ');
  readln(n);
  assign(f,'1.dat');
  rewrite(f);
  for i:=1 to n do
    write(f,Random(100)+1);
  reset(f);
  writeln('Исходный файл:');
  while not Eof(f) do
    begin
      read(f,x);
      write(x,' ');
    end;
  writeln;
  sum:=0;
  For i:=0 to FileSize(f)-1 do
    begin
      Seek(f,i);
      Read(f,x);
      if (x mod 5=0) and (x mod 10<>0) then
        begin
          sum:=sum+x;
        end;
      end;
  Close(f);
  writeln('Сумма: ',sum);
end.


Program KDSUP_2;
uses crt;
Type
   Eda=Record
       prod:string;
       ugl,bel,fat:real;
     end;
   ps=File of eda;
Var f:ps;
    i,n,m:Integer;
    z:eda;
Begin
  assign(f,'1.dat');
  rewrite(f);
  writeln('Ввести количество продуктов');
  readln(n);
  randomize;
  for i:=1 to n do
    begin
      z.prod:='Product_'+IntToStr(i);
      z.ugl:=random(100);
      z.bel:=random(100);
      z.fat:=random(100);
      write(f,z);
    end;
  Close(f);
  writeln('***************************************');
  writeln('*              М Е Н Ю                *');
  writeln('*     продукты с содержанием          *');
  writeln('*        белки: меньше 20             *');
  writeln('*         жиры: больше 10             *');
  writeln('*     углеводы: больше 30             *');
  writeln('***************************************');
  assign(f,'1.dat');
  reset(f);
  while not(eof(f)) do
    begin
      read(f,z);  
      if (z.ugl>30) and (z.bel<20) and (z.fat>10) then
         writeln('     ',z.prod);
    end;
  close(f);
end.

Ответить

Другие вопросы из категории

Среди всех натуральных четырехзначных чисел

подсчитать количество таких,
сумма квадратов цифр которых
кратна двум или трем.
Ответ записать целым числом.

Читайте также

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.

Дан файл f, компоненты которого являются целыми числами.

Найти количество квадратов нечетных чисел среди компонент файла. Записать это значение в начало нового файла g. Остальные значения переписать из исходного файла f.

Нужно написать программу... Задание: Адрес, запрашиваемый пользователем, обычно состоит из четырех частей, из которых первые три

являются доменными именами различного уровня и разделены точками, а последняя отделена от них двоеточием и является портом, к которому обращается пользователь. Например, при обращении пользователя к www.ifmo.ru:8080 слово ru является доменным именем первого уровня, слово ifmo — доменным именем второго уровня, слово www — доменным именем третьего уровня, а 8080 является портом.

Вам необходимо по списку запросов пользователей в таком формате перечислить все различные порты, к которым обращались пользователи.

Формат входного файла

В первой строке входного файла input.txt находится одно натуральное число n (1 ≤ n ≤ 100) — количество адресов в данном вам списке. В следующих n строках содержатся сами адреса в формате, описанном выше.

Все доменные имена всех уровней состоят только из строчных букв латинского алфавита, а порты — только из цифр. Длина любого данного вам адреса не превышает 250 символов.

Формат выходного файла

В первой строке выходного файла output.txt выведите одно целое число k — количество различных портов, к которым обращались пользователи. В следующих k строках выведите сами порты. Каждый порт должен быть выведен ровно один раз в отдельной строке. Порты могут быть выведены в любом порядке.

Пример входных и выходных данных

input.txt


3
www.ifmo.pl:3389
www.ya.pl:65535
www.ifmo.kz:3389

output.txt

2
65535
3389



Вы находитесь на странице вопроса "1.Построить файл данных, компонентами которого являются натуральные числа. Подсчитать сумму тех компонент, которые делятся на 5 и не делятся на 10.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.