Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

нужно составить программу в паскале по алгаритму

10-11 класс

начало
ввод A,B,C
A>B
да нет
A>C B>C
да нет да нет
D:=A D:=C D:=B D:=C
вывод D
конец

Nyamasha 04 янв. 2014 г., 10:53:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Matvei
04 янв. 2014 г., 12:45:14 (10 лет назад)

var a,b,c,d:integer;
Begin
readln(a);
readln(b);
readln(c);
if(a>b) then
begin
if(a>c) then d:=a else d:=c;
end
else if(b>c) then d:=b else d:=c;
writeln('D=',d);
end.

Ответить

Другие вопросы из категории

Опишите, какие действия с информацией (информационные процессы) будут выполнены учеником, если он: а) учит правило - запись информации

в память

б) решает у доски задачу -

в) слушает музыку;

г) пишет письмо;

д) переводит текст с английского языка на русский;

е) пишет диктант.

помогите пожалуйста:

Напиши цифровой фильтр. На вход программе подаётся строка символов. На выходе должны быть только её цифры. Например, если на входе была строка
He110, k177en!
то на выходе должно быть
110177

2. В строке, состоящей из слов, разделённых одним или несколькими пробелами, вывести второе слово. Например, если на вход программе подавалась строка
Меня истина манит сияньем
то на выходе будет
истина

На вход подаётся строка. Вывести часть входной часть строки. Часть строки задаётся номером первого символа и количеством символов.

var
s: string;
n, k, i: integer;
Begin
readLn(s, n, k);
for i := n to n+k-1 do write(s[i]);
End.


2. На вход подаётся предложение на английском языке. Вывести все гласные строки в том порядке, в котором они встречались в строке.


(ключевой фрагмент)
for i := 1 to length(s) do
if s[i] in ['A', 'E', 'I', 'O', 'Y', 'a', 'e', 'i', 'o', 'y']
then write(s[i]);


Варианты программы определения, является ли строка полиндромом
--------------------------------------------------------------
var
s, s1: string;
i: integer;
Begin
readLn(s);
s1 := '';
for i := 1 to length(s) do s1 := s[i] + s1;

write('строка ');
if s1 <> s then write('не ');
writeLn('является полиндромом');
End.



var
s: string;
i, j: integer;
Begin
readLn(s);

i := 1;
j := length(s);
while (i < j) and (s[i] = s[j]) do begin
inc(i);
dec(j);
end;
write('строка ');
if s[i] <> s[j] then write('не ');
writeLn('является полиндромом');
End.


Читайте также

Нужно составить программу с предусловием и постусловием!

Составить программу к.т. запрашивает буквы, пока не введут точку и находит количество букв "0".

Составить программу в паскале по подсчету кол-ва претендентов, которые попадут в школьную баскетбольную команду,если рост игрока должен быть не менее

170 см. Считать число претендентов случайном числом в диапазоне от 150 до 200, число претендентов 50 (программу писать через массив)

Помогите срочно нужно написать программу в Паскале по ветвлениям)

Ввести последовательно возраст Антона,Бориса и Виктора. Определить,кто из них старше. Пример:
Возраст Антона: 15
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Борис старше всех.

Пример:
Возраст Антона: 17
Возраст Бориса: 17
Возраст Виктора: 16
Ответ: Антон и Борис старше Виктора.

Заранее спасибо большое)

нужно составить программу в паскале

Царевна-лягушка съедает ежедневно на 20 % комаров больше, чем в предыдущий день, и еще 2 комара. Через сколько дней количество съеденных комаров в день превысит 100, если в первый день было съедено 12 комаров.

Воспользуйтесь словесным алгоритмом.
1)i:= 1
2)s:=12
3)если s<=100, то п.4, иначе 6
4)i:=i+1
5)s:=1.2*s+2, перейти к п.3
6)вывод i
7)конец



Вы находитесь на странице вопроса "нужно составить программу в паскале по алгаритму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.