Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Определить кол-во простых чисел,содержащихся в заданной последовательности n1 n2.. n20 (алгоритм Паскаль)

10-11 класс

Lena3027 31 марта 2015 г., 3:56:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
FIFA13poshla
31 марта 2015 г., 6:31:44 (9 лет назад)

function IsPrime(n: integer): boolean;
  // Проверка, является ли число простым
var
  p: integer;
  found: boolean;
begin
  found := (n mod 2 = 0);
  p := 3;
  while (not found) and (sqr(p) <= n) do
  begin
    found := (n mod p = 0);
    p := p + 2
  end;
  IsPrime := (not found) or (p = 2)
end;

const
  n = 20;

var
  i, k: integer;
  a: array[1..n] of integer;

begin
  Write('Введите 20 целых чисел через пробел: ');
  for i := 1 to n do
  begin
    Read(a[i]);
  end;
  k := 0;
  for i := 1 to n do
    if IsPrime(a[i]) then k := k + 1;
  Writeln('Количество простых чисел- ', k)
end.

Тестовое решение:

Введите 20 целых чисел через пробел: 5 36 83 1673 339 73 34 14623 7 173 62 45 3463 326 28 934 345 24 4526 1143
Количество простых чисел- 6



+ 0 -
Katrina992011
31 марта 2015 г., 9:14:03 (9 лет назад)

Последовательность - просто набор чисел, вводимых с клавиатуры?

+ 0 -
Natali1234
31 марта 2015 г., 11:02:46 (9 лет назад)

Ладно...принимаем решение самостоятельно

Ответить

Другие вопросы из категории

Написать программу вычисления площади кольца. Ниже приведен рекомендуемый вид экрана во время выполнения программы.

Вычисление площади кольца
Введите исходные данные:
Радиус внешнего круга (см):
Радиус внутреннего круга (см):

Площадь внешнего круга:
Площадь внутреннего круга:
Площадь кольца:

Читайте также

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

Раскодируйте последовательность, упакованную с помощью алгоритма RLE (шестнадцатирич.коды) : 01 4D 8E 41 01 4D 8E 41. Использовать таблицу ASII.

Определите кол-во байтов в исходной и распакованной последовательности и вычислите коэффиц.сжатия.



Вы находитесь на странице вопроса "Определить кол-во простых чисел,содержащихся в заданной последовательности n1 n2.. n20 (алгоритм Паскаль)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.