Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача:

10-11 класс

Составить программу расчёта числа загонов (шт.) на пастбище по формуле:

Maks37 04 дек. 2014 г., 4:23:18 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kate240500
04 дек. 2014 г., 5:50:24 (9 лет назад)

program qq;
uses crt;
var p, d, z, i: integer; k:real;
begin
writeln('Введите период для отрастания травы в днях:');
readln(p);
writeln('Введите потребное количество загонов:');
readln(z);
for i:=1 to 5 do
    begin
    d:=i; // переменная дней изменяется, как дано в условии от 1 до 5 дней
    k:=round(p/d+z); //процедура round округляет по всем правилам число загонов. Ведь весьма нелогично строить, например 3,3333 загона:)
    writeln ('Для количества дней пастьбы - ', d,' требуется загонов - ',k);
    end;
end.

Ответить

Другие вопросы из категории

Заполнить массив из 10 элементов случайными числами в интервале [0..100] и отсортировать его по последней цифре. Пример: Исходный

массив:

14 25 13 30 76 58 32 11 41 97

Результат:

30 11 41 32 13 14 25 76 97 58

говорили про какой-то метод пузырька. хелп ми Т_т

p.s. паскаль abc

ребят ,если честно - срочно...

Читайте также

Задача первая.

Дан массив O ( K ). Заменить все положительные числа квадратом числа,а отрицательные модулем.
Задача вторая.
Дан массив R ( 6 ) .Найти сумму и произведение всех элементов массивов.

Через Qbasic

ОТ CLS ДО ЕND

Задача № 1

Тронувшись с места, автомобиль каждую секунду увеличивает скорость на а км/ч.
На этом участке дороги существует ограничение V км/ч. Выяснить, через сколько полных секунд автомобиль превысит предельно допустимую скорость V?
Задача №2
Даны действительные числа а, b, c. Определить, можно ли построить треугольник со сторонами а, b, c или нет
Язык ПАСКАЛЬ =)

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

реализовать задачу на компьютере, используя операторы цикла и вложеннные операторы цикла.

задача. даны площади нескольких квадратов. найти длину диагонали самого большого из них.



Вы находитесь на странице вопроса "Задача:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.