Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

найти максимальный по модулю элемент массива,массив состоит из n вещественных чисел . Помогите пожалуйста))

10-11 класс

Anyta97chumova 21 апр. 2015 г., 3:12:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Milkmilkmilk
21 апр. 2015 г., 6:03:54 (9 лет назад)

 

uses crt;
var a:array[1..99] of real;
i,j,n:integer;
max:real;
begin
write('Введите n: ');
readln(n);
writeln('Исходный массив: ');
for i:=1 to n do begin
a[i]:=random(99-(-99)+1)-99;
write(a[i]:5);
end;
writeln;
max:=-5;
for i:=1 to n do begin
if abs(a[i])>max then begin max:=abs(a[i]);j:=i; end;
end;
writeln('Максимальное по модулю число равно ',a[j]);
end.


Здесь элементы массива - случайные числа от -99 до 99. В ответе выписывается само число, а не его модуль. Если нужен именно модуль, то меняем предпоследнюю строку на writeln('Максимальное по модулю число равно ',max);

Ответить

Другие вопросы из категории

Помогите решить задачку очень-очень надо:)) спасибо:* Устав от повседневных дел, Иван Петрович устроил себе отпуск - пошел на охоту. На

расстоянии N метров, его охотничья собака Гайзарда заметила зайца. Через какое время она догонит его если скорость зайца V1 м / с, а скорость собаки V2 м / с? Следует отметить, что Гайзарда бегает быстрее любого зайца.
Входные данные:
Программа на вход получает три целых числа N, V1, V2 (0 ≤ N ≤ 103, 0 <V1, V2 <20).
Выходные данные:
Программа должна вывести время за собака догонит зайца с точностью до сотых.

PASCAL.

Дана строка, среди которой есть символы / \ | . Посчитать их количество(по отдельности).

Документ объёмом 8 Мбайт можно передать с одного компьютера на другой

двумя способами:
А) сжать архиватором, передать архив по каналу связи, распаковать;
Б) передать по каналу связи без использования архиватора.
Какой способ быстрее и на сколько, если:
• скорость передачи данных по каналу связи составляет 221 бит/с;
• объём сжатого архиватором документа равен 50 % от исходного;
• время, требуемое на сжатие документа, – 10 секунд, на распаковку –
3 секунды?
В ответе напишите букву А, если быстрее способ А, или Б, если быстрее
способ Б. Сразу после буквы напишите число, обозначающее, на сколько
секунд один способ быстрее другого.
Так, например, если способ Б быстрее способа А на 23 секунды, в ответе
нужно написать Б23.
Единицы измерения «секунд», «сек.», «с» к ответу добавлять не нужно.

Читайте также

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}


Задача. Линейный массив (вектор) T, размерностью 31 элемент заполнен целыми случайными числами, сгенерированными в интервале [-10;

10]. Необходимо:

определить максимальный по модулю элемент массива; вывести номер (любого, если их несколько) и значение такого элемента; определить, сколько в предложенном массиве таких элементов и вывести их номера.



Вы находитесь на странице вопроса "найти максимальный по модулю элемент массива,массив состоит из n вещественных чисел . Помогите пожалуйста))", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.