Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите написать программу в паскале:Даны две строки: S1 и S2. Можно ли из символов строки S1 составить строку S2? Регистр значения не имеет.

10-11 класс

(например

a) S1=’april’, S2=’may’. Ответ: false

b) S1=’Rom’, S2=’room’. Ответ: false, т.к. буква ‘o’ встречается в строке S1 один раз.

c) S1=’tomorrow’, S2=’mOtOr’. Ответ: true)


Valeranikolaev 30 янв. 2017 г., 21:58:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Radima6674
31 янв. 2017 г., 0:33:29 (7 лет назад)

var
  i,n:integer;
  s1,s2:string;
  f:boolean;
begin
f:=true;
writeln('Введите первую строку');
readln(s1);
writeln('Введите вторую строку');
readln(s2);
s1:=LowerCase(s1);
s2:=LowerCase(s2);
i:=1;
repeat
  n:=pos(s2[i],s1);
  if n>0 then delete(s1,n,1) else f:=false;
  i:=i+1;
  until i=length(s2);
writeln(f)
end.

Ответить

Другие вопросы из категории

Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F. Какое

выражение соответствует F?

X Y Z F

0 1 0 1

1 0 0 1

0 1 1 0

-x * -y * -z

x + -y + -z

-x * y * -z

-x + y + -z

Составить алгоритм

вычисления значения суммы членов
бесконечного ряда методом итераций s = 1 +

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.


Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.



Вы находитесь на странице вопроса "помогите написать программу в паскале:Даны две строки: S1 и S2. Можно ли из символов строки S1 составить строку S2? Регистр значения не имеет.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.