Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Есть программа, код приложу,нужно ее переделать используя счетчик.Если не сложно прокомментируйте нововведения.

10-11 класс

program pr3;
const a = 2.12;
const b = 7.45;
const h = 0.34;
var x, f1, f2, y, s: real;
begin
x := a;
s := 0;
REPEAT
f1:=3*ln(exp(1/5)*ln(sin(x)+sqr(x)));
f2:=((2*x+1)/(x*x*x*x*x));
y := f1 / f2;
s := s + y;
x := x + h;
UNTIL x > b;
Writeln('S=', s:10:5);
end.

Botvin2005 09 апр. 2014 г., 4:54:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alenayakovleva2
09 апр. 2014 г., 6:30:08 (10 лет назад)

program pr3;

const {убраны лишние описатели - чистая косметика}
  a = 2.12;
  b = 7.45;
  h = 0.34;

var
  x, f1, f2, y, s: real;
  i, n: integer; {описание, необходимое для цикла}

begin
  { x := a; этот оператор не нужен }
  s := 0;
  n := Trunc((b - a) / h)+1; {стандартная формула числа повторений цикла }
  for i := 1 to n do { Заголовок цикла }
  begin   {начало блока для выполнения в цикле }
    x := a + (i - 1) * h;  { перенесено из конца цикла }
    f1 := 3 * ln(exp(1 / 5) * ln(sin(x) + sqr(x)));
    f2 := ((2 * x + 1) / (x * x * x * x * x));
    y := f1 / f2;
    s := s + y;
  end;  {конец блока для выполнения в цикле }
  Writeln('S=', s:10:5);
end.

Тестовое решение:

S=26390.53751






+ 0 -
Striga1998
09 апр. 2014 г., 9:25:02 (10 лет назад)

но уже поставил нужный вариант,гляньте пожалуйста

+ 0 -
Annna050902
09 апр. 2014 г., 11:48:47 (10 лет назад)

xtnxbr - 'nj wbrk cj cxtnxbrjv&

+ 0 -
Anyakuznetsova
09 апр. 2014 г., 13:27:31 (10 лет назад)

Ой... счетчик - это цикл со счтчиком for...do?

+ 0 -
Alenuchca
09 апр. 2014 г., 14:06:46 (10 лет назад)

да

+ 0 -
Elena77741
09 апр. 2014 г., 16:22:47 (10 лет назад)

что то я не пойму как его тут применить(

Ответить

Другие вопросы из категории

Определите значение переменной K после выполнения следующей программы a=-5; b=-12; c=0; d=7; k=0

если a<0 то k:=k+1
все
если b<0 то k:=K+1
все
если c≤0 то k:=k+1
все
если d<0 то k:=k+1
иначе k:=k+2
все

В поселке 80 домов: деревянные, кирпичные и панельные. Сообщение о том, что покрасили деревянный дом, содержит 2 бита информации. Сколько деревянных, ки

рпичных и панельных домов в поселке, если панельных домов столько же, сколько кирпичных?

информатика,эксель. помогите
Ребят, помогите пожалуйста объяснить задачи!!!

В целочисленной
последовательности есть нулевые элементы. Создать массив из номеров этих
элементов.



Program
Om1;

Uses
crt;

Var

a :array
[1..100] of real;

i,n,j :
integer;

x :
array [1..100] of real;

Begin

clrscr;

write('n=');readln(n);

for i:=1
to n do

readln(a[i]);

j:=1;

for i:=1
to n do

if
a[i]=0 then

begin

x[j]:=i;

j:=j+1

end;

for i:=1
to j-1 do

write(x[i],' ');

End.


Дана последовательность
целых чисел а1, а2….аn.
Выяснить какое число встречается раньше, положительное или отрицательное.


Program
num2;

Uses
crt;

VAr

a :array
[1..100] of real;

i,n :
integer;

Begin

clrscr;

write('n=');readln(n);

for i:=1 to n do

readln(a[i]);

for i:=1
to n do

begin

if
a[i]<>0 then

if
a[i]>0 then

begin

writeln('Положительное встречается раньше');

break

end else

begin

writeln('Отрицательное встречается раньше');

break

end;

end;

End.


Дана последовательность
действительных чисел а1, а2….аn. Выяснить будет ли она возрастающей.


Program
num4;

Uses
crt;

Var

a :
array [1..100] of real;

i, n, j
:integer;

Begin

clrscr;

write('n=');readln(n);

a[n+1]:=a[n]+1;

for i:=1
to n do

readln(a[i]);

j:=0;

i:=1;

while
i<n do

begin

if
a[i]<a[i+1] then

begin

j:=j+1;

i:=i+1

end

else

begin

writeln('Последовательность невозрастающая');

break

end;

end;

if i=n then writeln('Последовательность возрастающая');

End.




Найти самую большую цифру
целого числа.


Program
rar;

uses
crt;

var
n:longint;

b:byte;

Читайте также

В чём ошибка программы? Если не сложно объясните .

код программы -
Program cikl;
Uses GraphABC;
Var
r:Integer;
begin
for r:=460 downto 100 do
begin
circle(620,480,r);
r:=r-35;
end;
FloodFill(170,480,clPurple);
FloodFill(205,480,clBlue);
FloodFill(240,480,clSkyBlue);
FloodFill(275,480,clGreen);
FloodFill(310,480,clYellow);
FloodFill(345,480,clLime);
FloodFill(380,480,clMoneyGreen);
FloodFill(415,480,clRed);
FloodFill(450,480,clMaroon);
FloodFill(485,480,clBrown);
FloodFill(620,480,clNavy);
End.


Ошибка которую выдаёт программа -
Program1.pas(9) : Нельзя изменять значение переменной цикла внутри этого цикла

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите, пожалуйста! Есть код программы в QBasic, нужно продолжить блок-схему.

Дана квадратная матрица. Найти минимальное значение среди элементов, расположенных выше главной диагонали.

Вася уехал на отпуск в Японию. По возвращению он понял что забыл пароль от архива.

Но он точно помнит что пароль состоит и 4 символов. Так же он помнит что в пароле присутсвуют цифры от 1 до 9 и буквы латинского алфавита от A до Z. У Васи есть программа для подстановки, но ей нужны база паролей.Помогите Васе написать программу, для базы паролей



Вы находитесь на странице вопроса "Есть программа, код приложу,нужно ее переделать используя счетчик.Если не сложно прокомментируйте нововведения.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.