Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Написать ПРОЦЕДУРУ перевода целого числа из десятичной системы в двоичную. ПАСКАЛЬ.ПРОЦЕДУРЫ И ФУНКЦИИ

10-11 класс

IlyaMaculevic 26 сент. 2013 г., 20:20:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
991166
26 сент. 2013 г., 22:12:04 (10 лет назад)

program perevod; 

Uses crt;
var z:integer;
procedure ToBin(z:integer);
begin
if (z>1) then ToBin(z div 2);
write(z mod 2:1);
end;

begin
clrscr;
  write('Введи число:');
readln(z);
  writeln('Число в десятичной системе:',z:6);
  write('Число в двоичной системе: ');
   ToBin(z);
readkey;
end.

+ 0 -
Magalo
27 сент. 2013 г., 0:50:02 (10 лет назад)

Не уверена, что поняла вопрос правильно, но всё-таки:

1. Разделить десятичное число на 2, получится частное и остаток.

2. Разделить частное на 2, получится частное и остаток.

3. Продолжать деление частных, пока последнее частное не будет меньше 2.

4. Последнее частное и остатки записать в обратном порядке.

Например, из 27 в десятичной = 11011 в двоичной.

Ответить

Другие вопросы из категории

как запускается программа Paint?
Написать программу на паскале: Дана матрица А, имеющая N строк и N столбцов.

Сформируйте два одномерных массива. В один перешлите четные, а в другой
-нечетные элементы матрицы. Выведите на экран все массивы.

создайте форму для проверки существования треугольника по заданным длинам сторон. в форме предусмотреть три ячейки для ввода длин а, в и с, ячейку с вариан

тами результата "треугольник существует" треугольник не существует". для существзвания треугольника необходимо, чтобы сумма длин любых двух сторон была больше длины третьей стороны. внутри функции ЕСЛИ используйте условие: И(а+в>с; а+с> в; в+с> а) . помогите пожалуйста не получается формулу вписать.. ( ms excel)

Дана

геометрическая прогрессия: 2, 6, 18, 54, … Найдите сумму первых n элементов
прогрессии, используя оператор repeat.

Читайте также

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

• Перевести данное число из десятичной системы счисления в двоичную, восьмеричную и шестнадцатеричную системы счисления:


1) 164.25
2) 520,375

• Перевести данное число в десятичную систему счисления:
1) 1110010100,1011001 (двоичная СС)
2) 1000000110,00101 (двоичная СС)
3) 666,16 (восьмеричная СС)
4) 1C7,68 (шестнадцатеричная СС)
*СС - система счисления.

Помогите пожалуйста написать программу в паскале.

Составить программу перевода натурального числа из десятичной системы счисления в двоичную

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "Написать ПРОЦЕДУРУ перевода целого числа из десятичной системы в двоичную. ПАСКАЛЬ.ПРОЦЕДУРЫ И ФУНКЦИИ", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.