Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1.Среди цифр четырехзначного числа есть четная. Накидал тут решение, но где-то ошибка, не могу

10-11 класс

понять где

var
t,s,d,e,i: integer;
begin
for i:= 1000 to 9999 do
t:=i div 1000;
s:=(i div 100)mod 10 ;
d:=(i div 10) mod 10;
e:=i mod 10;
if ((t mod 2=0) or (s mod 2 =0) or (d mod 2 =0) or (e mod 2=0)) then writeln ('TRUE') else writeln ('FALSE');
end.

Ceresha 01 сент. 2013 г., 17:02:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Xthysijdf
01 сент. 2013 г., 17:33:10 (10 лет назад)

Ну если задание что-то вроде "Есть ли среди 4х значного числа четные числа " 
то все гораздо проще да и непонятно зачем ты сделал цикл по всем 4х значными , но опять же задание не ясно! 

Ответить

Другие вопросы из категории

какое действие превратит ежа в ужа.
помогите пожалуйста:((
Написать программу, которая вводит массив с

клавиатуры, удаляет все четные элементы и выводит массив (с изменениями).

Рассказать и показать на примере Паскаль: 1) Что такое absolute и для чего нужна? 2) Что такое asm и для чего нужна? 3) Что такое

constructor и destructor и для чего нужна?

4) Что такое implementation и для чего нужна?

5) Назовите модули Паскаль ( в строке Uses, например crt) и какие возможности этот модуль дает?

6) Что за тип переменной: указательный (Pointer)

7) И на последок: что означает символ @ , #, $ , ^

В Турбо паскале Уже нужно

Составить программу для обработки массива содержащего 10 целых числе. Определить максимальный элемент массива. Выполнение каждого логического блока программы оформить в виде отдельных процедур

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести

произведение цифр этого числа.

Необходимо решение на языке Паскаль. Заранее спасибо!

Дано натуральное четырехзначное число. Средствами Microsoft Excel получить число: 1) образуемое при перестановке

первой и второй, третьей и четвертой цифр заданного числа. Например, из числа
5436 получить число 4563.



Вы находитесь на странице вопроса "1.Среди цифр четырехзначного числа есть четная. Накидал тут решение, но где-то ошибка, не могу", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.