Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

В последовательности натуральных чисел посчитать сумму всех чисел,кратных 4 и оканчивающихся на 8.

5-9 класс

Числа от 0 до 100
Использовать цикл.

Данил85 15 сент. 2014 г., 22:31:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vasya92938
16 сент. 2014 г., 1:14:00 (9 лет назад)

var
  sum, c : integer;
begin
  sum := 0;
  while not eoln do
  begin
    read (c);
    if (c mod 10 = 8) and (c mod 4 = 0) then sum := sum + c;
  end;
  write (sum);
end.

+ 0 -
Gggqqqww
16 сент. 2014 г., 3:11:00 (9 лет назад)

Program asd;
USES crt;
Const n=100;
VAR A:array[1..n] of integer;
i,s:integer;
BEGIN
s:=0;
For i:=1-1 to n do
 begin
 Write(i:4);
 If (i mod 4=0) and (I mod 10 in[8]) then
 begin
 S:=S+i;
 end;
 end;
 Writeln;
 Writeln(S);
END.
Вот так

+ 0 -
Warface41
16 сент. 2014 г., 5:21:41 (9 лет назад)

на каком языке?

+ 0 -
Серёжа05
16 сент. 2014 г., 6:32:03 (9 лет назад)

Паскаль

Ответить

Другие вопросы из категории

Волк погнался за зайцем по бесконечной дороге. Когда волк делает m скачков, заяц делает n скачков. Скачок зайца в 2 раза короче скачка волка, а скачок

волка равен k метров. Какое расстояние пробежит волк, чтобы догнать зайца. Если первоначальное расстояние между ними равно d

Трехзначное десятичное число оканчивается цифрой 3. Если эту цифру переместить на первое слева место в числе, то есть с нее будет начинаться запись нового

числа, то это новое число будет на единицу больше утроенного исходного числа. Найдите исходное число.

Читайте также

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на

вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. Пояснение: цикл while x<>0 do с условием if (x mod 6=0) and (x mod 10=4)

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!



Вы находитесь на странице вопроса "В последовательности натуральных чисел посчитать сумму всех чисел,кратных 4 и оканчивающихся на 8.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.