Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводят слово и символ. Составьте программу, которая определяет позицию заданного символа.

10-11 класс

Alexs1999 02 февр. 2017 г., 1:45:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
дідПавло
02 февр. 2017 г., 4:05:20 (7 лет назад)

program xxx;

var a,s : string;

   i:integer;

begin

   writeln ('Введите слово и символ-');

   readln (s,a);

   for i:=1 to length(a) do

     if copy (s,i,1)=a then writeln (i);

   readln

end.

 

+ 0 -
Arsenmakarov02
02 февр. 2017 г., 5:49:58 (7 лет назад)

паскаль:

 

uses crt;

var a,b:string;\ а-слово ,b-символ

i:integer;\ переменная для счета

begin

writeln ('Слово и символ');

readln (a,b);\\ввод данных

 

for i:=1to length(a) do if copy (a,i,1)=b then writeln (i);\\Копирование по порядку символов слова а  и сравнение каждого с символом b. Вывод ответа. Или ответов 

readkey;\\если символы в слове повторяются

end.

 

 

Ответить

Другие вопросы из категории

Дана матрица размера M × N и целые числа K1 и K2 (1 ≤ K1 < K2 ≤ M).

Поменять местами строки матрицы с номерами K1 и K2.

Решить в Pascal. Перед тем как выложить, проверить свое решение.

Прошу вас, чистейшие умы,помогите мне,бестолочу, перевести эти цифры в буквы.Буду

благодарна!
0011010100100000111000011110000011101011111010111110111011100010

Читайте также

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.

Решите пожалуйста,очень нужно! С клавиатуры вводят слово и символ. Составьте программу,которая:а)проверяет,есть ли в этом слове заданный

символ;б)определяет позицию заданного слова;в)подсчитывает количество вхождений заданного символа.



Вы находитесь на странице вопроса "С клавиатуры вводят слово и символ. Составьте программу, которая определяет позицию заданного символа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.