Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Для заданного массива из 10 элементов определить ,каких элементов больше:положительных или отрицательных.Паскаль.

10-11 класс

Oladin 18 мая 2014 г., 11:08:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Киса962
18 мая 2014 г., 13:17:09 (9 лет назад)

var
  plus, minus, i : integer;
  arr : array [0..9] of integer;
begin
  //Заполнение массива случайными числами
  for i := 0 to 9 do
    arr[i] := Random(1000) - 500;
  plus := 0;
  minus := 0;
  for i := 0 to 9 do
    if arr[i] > 0 then Inc(plus)
    else if arr[i] < 0 then Inc(minus);
  if plus > minus then WriteLn('Положительных чисел больше')
  else if plus < minus then WriteLn('Отрицательных чисел больше')
  else WriteLn('Поровну');
end.

Ответить

Другие вопросы из категории

Перевести

число 35,6410 двоичную, восьмеричную, а также шестнадцатеричную системы.
Ответ проверить обратным переводом. Указание: обдумайте, как проще
перевести из двоичной системы в восьмеричную и шестнадцатеричную.





Написать программу в Pascal ABC чтобы полностью работала, которая ввод данных

в одномерный целочисленный массив осуществляет посредством цикла WHILE…DO, а вывод - REPEAT…UNTIL (в скобках указана размерность
массива).

Документ объемом 5 Мбайт можно передать с одного компьютера на другой двумя способами:

А) Сжать архиватором, передать архив по каналу связи, распаковать.
Б) Передать по каналу связи без использования архиватора.
Какой способ быстрее и насколько, если
– средняя скорость передачи данных по каналу связи составляет 218 бит в секунду,
– объем сжатого архиватором документа равен 80% от исходного,
– время, требуемое на сжатие документа – 35 секунд, на распаковку – 3 секунды?

Читайте также

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

Паскаль,помогите!!! В числовом массиве из 10 элементов, заданных случайным образом от -100 до 500. Найти: 1) сумму положительных элементов,

стоящих на чётных местах; 2) произведение элементов массива, кратных 3 и стоящих на нечётных местах;



Вы находитесь на странице вопроса "Для заданного массива из 10 элементов определить ,каких элементов больше:положительных или отрицательных.Паскаль.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.