Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Построить

10-11 класс

таблицу функции «y» на отрезке [a;b] с шагом «h», вводя соответствующую функцию
в разделе Function: y=3x+x2 ,если x<0; y=3-x-x-2, a=-1; b=2; h=0.2;

Renatsamigullin 07 февр. 2016 г., 22:53:54 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Полькаааааа95
08 февр. 2016 г., 0:39:20 (8 лет назад)

const
  a = -1.0; b = 2.0; h = 0.2;

var
  x, y, ln3: real;

begin
  x := a;
  ln3 := ln(3);
  while x <= b do
  begin
    if x < 0 then y := 3 * x + sqr(x)
    else y := exp(-x * ln3) - 1 / sqr(x);
    writeln(x, ' ', y);
    x := x + h
  end
end.

Результаты:
-1 -2
-0.8 -1.76
-0.6 -1.44
-0.4 -1.04
-0.2 -0.56
-5.55111512312578E-17 -1.66533453693773E-16 <----- Не знаю, почему тут не 0...
0.2 -24.1972584382398
0.4 -5.60560598502275
0.6 -2.26049591980599
0.8 -1.14725635346149
1 -0.666666666666667
1.2 -0.426863923857701
1.4 -0.295406076640235
1.6 -0.218197714009405
1.8 -0.170227426462473
2 -0.138888888888889


+ 0 -
БуБлИг
08 февр. 2016 г., 2:25:13 (8 лет назад)

Комментарий удален

+ 0 -
WeKa1999
08 февр. 2016 г., 3:02:27 (8 лет назад)

y=3 в степени x + х квадрат, если x<0, y=3 в степени минус х минус х в степени минус 2, a=-1; b=2; h=0.2;

+ 0 -
Wdsfsfsfsf
08 февр. 2016 г., 4:26:37 (8 лет назад)

Комментарий удален

+ 0 -
Lerakrava
08 февр. 2016 г., 5:12:16 (8 лет назад)

Pascal ABC

Ответить

Другие вопросы из категории

В паскале нужно:

Вычислить сумму 4 целых чисел(любых) и вывести развернутое сообщение о проведеной операции

умоляю,Пожалуйста помогите составить программу.Заполнить массив из 500 элементов случайными числами в интервале [ 0 .. 100 ] . Отсортировать его по

возрастанию двумя способами – методом «пузырька» и методом «быстрой сортировки» .

Как решить? A2 ЕГЭ информатика.
Помогите составить программу Borland Pascal

Вывести 150 чисел начиная с даты рождения.В порядке возрастания и в порядке убывания.В моем случае от 17 до 150.
Еще что-то преподаватель дал
1.параметр
2.предусловие
3.постусловие паскаль

Читайте также

Помогите пожалуйста! 1)Построить развлетвляющийся алгоритм, записать алгоритмы ввиде блок-схемы и на алгоритмическом языке. Треугольник задан

длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным.

2) Построить циклический алгоритм, записать ввиде блок-схемы и на алгоритмическом языке.

Построить алгоритм, который определяет количество студентов в группе,
чей рост превышает среднее для группы значение.

Cоздать пользовательскую функцию и построить ее график для х от -5 до +5,с шагом 0,5 Y=\begin{cases}2cos^2(x),x ≤0\\ |2-x |^1/3,x

>0\end{cases}.

Функцию я построить сама смогла б,но я не знаю как туда это уравнение записать.можно ли его как -то упростить,чтоб все в одной строчке было.Вот фото уравнения на всякий случай,вдруг я его не правильно написала.Помогите пожалуйста.Тут в Excele надо работать

Ребят, помогите, пожалуйста! В excel нужно построить на промежутке [-2;2] с шагом 0,4 таблицу значений функции: y= x в квадрате+0,2х для х меньше равно 0,

sin(0,1x) для х больше равно 0. Построить график полученной функции. Спасибо заранее

Помогите, пожалуйста, решить задачу:

Дан вектор из 25 элементов. Найти минимальное значение. Записать на языке Pascal и построить алгоритм.



Вы находитесь на странице вопроса "Построить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.