Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

СИ++ Составить программу, печатающую все простые числа из диапазона [2, n] при целом n > 2.

10-11 класс

Varva483jdj 10 марта 2017 г., 4:59:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rikki966
10 марта 2017 г., 5:32:11 (7 лет назад)


#include <iostream>
using namespace std;
int isSimple (int x)
{
int retVal = 1;
int i = 2;
while (i<=sqrt((double)x) && retVal==1)
{
if (x%i==0) retVal=0;
i++;

}
return retVal;
}

void main(){
int n(0);
cout<<"write n "; cin>>n;
if (n < 3)
cout<<"error";
else {
for (int i=2;i<=n;i++)
if (isSimple(i)) cout<<i<<" ";
}
cout<<endl;
system("pause");
}

Ответить

Другие вопросы из категории

Помогите пожалуйста!!! Задачи в паскале:

1) Дана длина ребра куба, найти Sгр, Sполн и V куба
2) Вычислите корни кв ур ах2+вх+с=0 заданными коэффициентами а, в, с

ПОМОГИТЕ СОСТАВИТЬ ПРОГРАММУ В ПАСКЛЕ

составить подпрорамму формирования вектора из элементов нижней треугольной матрицы с выводом количества полученыч элементов.
С помощью этой подпрограммы сформировать вектор и вынести количество полученых элементов из целочисленной матрицы A(-3:2,0:5).

Читайте также

помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1.дано целое k>2. напечатать все простые числа из диапазона [2,k]

2.найти первое число Фибоначчи, большее заданного n (n>1).



Вы находитесь на странице вопроса "СИ++ Составить программу, печатающую все простые числа из диапазона [2, n] при целом n &gt; 2.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.