Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Случайным образом задано 1000<n<=9999. Выяснить, различны ли все цифры этого числа. Pascal ABC

5-9 класс

Nikita93r1 06 янв. 2015 г., 14:55:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
11lutyi11
06 янв. 2015 г., 17:45:38 (9 лет назад)

var
a:array[1..100]of integer;
n,i,c,k,j,x:integer;
begin
readln(n);
c:=n;
while n<>0 do begin
n:=n div 10;
k:=k+1;
end;
for i:=1 to k do begin
a[i]:=c mod 10;
c:=c div 10;
end;
for i:=1 to k do
write(a[i],' ');
j:=2;
for i:=1 to k do begin
while j<>k do begin
if (a[i]=a[j]) and (i<>j) then
x:=x+1;
j:=j+1;
end;
j:=2;
end;
writeln;
write(x,'  повторов');
writeln;i
f x=0 then writeln('все числа различны')
else writeln('числа в числе повторяются')
end.

+ 0 -
GigaSetUser
06 янв. 2015 г., 18:58:44 (9 лет назад)

3 мин жди)

Ответить

Другие вопросы из категории

Посоны, у меня не запускается комп ( 7 винда). Вхожу в систему, предлагает ее просто запустить или с восстановлением запуска. Но он после проверки пишет,

что не смог найти ошибку (см. вложение,1-2). Восстановление системы пробовал, сказал, что все файлы на месте, только не захотел менять один файл - см. в вложениях (3 изображение). Помогите поподробнее плиз.
З.Ы.возможно проблема в системном файле?
З.Ы.Ы пишу с планшета

Помогите! Срочно надо! Информатика 9 класс

Линейна структура:
1) Найти значение выражения y=ax^2+bx+c
2) Вычислить площади треугольника, прямоугольника, ромба.
3) Найти среднее арифметическое трёх чисел.

Читайте также

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.

С клавиатуры вводятся два натуральных числа N и K (0<N<=K<=200000). Требуется написать программу, которая находит сумму простых чисел,

расположенных между N и K(включая эти числа).
Пример входных данных: 2 5
Пример выходных данных: 10



Вы находитесь на странице вопроса "Случайным образом задано 1000&lt;n&lt;=9999. Выяснить, различны ли все цифры этого числа. Pascal ABC", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.