Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

по веденному номеру билета определить счастливый ли он ,все это нужно на языке паскаля

5-9 класс

Colosowmaxim2015 23 июля 2016 г., 14:34:41 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
рафка
23 июля 2016 г., 15:44:16 (7 лет назад)

program schaslivyi;

uses crt;

var a,b,c,d,e,f,g,x,y:real;

begin

write('vvedite nomer bileta: ');

readln(g);

f:=g mod 10;

e:=g mod 100 div 10;

d:=g mod 1000 div 100;

c:=g mod 10000 div 1000;

b:=g div 10000 mod 10;

a:=g div 100000;

x:=a+b+c;

y:=d+e+f;

if x=y then write('schactlivyi') else write('ne schactlivyi');

readln;

end.

 

если есть возможность проверить, то лучше это сделать, так как я могу ошибаться в количестве нулей при отделении цифр.

Ответить

Другие вопросы из категории

Тема: Pascal.Циклы

1)Напечатать таблицу умножения на 6(умножение от 1 до 9)
2)Найти сумму всех трехзначных чисел,кратных 3
3)Вычислить сумму 1+1/2+1/3+...+1/n

даны 2 числа : 113 в 10-ой системе и 28 в 10-ой.

перевести их из десятичной системы счисления в двоичную с проверкой.
из десятичной в шестнадцатеричную с проверкой .
рузультат перевода в двоичную систему счисления сложить и умножить.

Запишите в традиционной

математической форме (при записи нельзя использовать трех- и четырехэтажные
дроби) :

Читайте также

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Определить, счастливый ли билетик.

С помощью 2 массивов. Принцип такой: на билете 6 цифр. Если сумма первых трех будет равна сумме следующих трех, то билет-счастливый.

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

1)составить программу, которая подсчитает объем любого шара по формуле: V=4/3Пr^3 2)даны действительные числа x и y. необходимо определить

принадлежит ли точка с координатами (x,y) окружности с радиусом R и центром в точке (x1,y1).

3)дан одномерный числовой массиф В(16). Необходимо вывести на экран индексы элементов значения, которых равны числу P.

cрочно надо на языке паскаль составить плиз)



Вы находитесь на странице вопроса "по веденному номеру билета определить счастливый ли он ,все это нужно на языке паскаля", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.