Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите решить задачу на Кумире: Дан массив. Напечатать все элементы, не превышающие числа 100. Заранее благодарен)))

5-9 класс

Artem021 23 окт. 2014 г., 17:06:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
CatrineDeMewMEW
23 окт. 2014 г., 19:27:15 (9 лет назад)

var
n, i: integer;
a:array of integer;
begin
readln(n);
setlength(a, n+1);
for i:=1 to n do read(a[i]);
for i:=1 to n do if a[i]<=100 then write(a[i], ' ');
end.


n - размер массива. n вводится в начале, а затем уже вводится n чисел в массиве.
Если возникнут вопросы или будут ошибки в ходе работы программы, пиши в комментарии.

Ответить

Другие вопросы из категории

101001-110110= решить столбиком
Кто нибудь помогите разобраться!!!!Я сдаю информатику,все знаю кроме Паскаля блин! Что тут написано на русском языке?И пожалуйста распишите значение

каждого слова integer - а то в инете поискал фиг че поймешь там!! Короче вот:

var s, n: integer

begin

s:=0

for n:=1 to 10 do

s:= s+7

end.

1)Статья, набранная на комп., содержит 16 страниц, на каждой странице 40 строк, а в каждой строке 64 символа. Определите информационный объём статьи,

если документ представлен в кодировке КОИ-8(каждый символ занимает 8 бит памяти)
2) Сколько памяти( в Кбайтах) требуется для сохранения 64-цветного изображения размером 32*64 пикселей.
3)Сообщение, записанное буквами 64-символьного алфавита, содержит 480 символов. Какое кол-во инф. в байтах оно несёт?
4) Информационное сообщение объемом 2000 битов состоит из 250 символов. Какова мощность алфавита, с помощью которого оно записано?
Даже если что то не знаете напишите хотябы свои предположения, или только что можете решить.

Читайте также

№1. Дан массив напечатать:

1)все неотрицательные элементы.
2)все элементы не превышающие числа 10

№2
дан массив целых чисел.Напечатать:
1)все элементы кратные 5
2)все элементы заканчивающиеся 0

Помогите решить задачи на паскаль.

1)
Дан массив случайных чисел (количество элементов
вводите с клавиатуры). Найти произведение всех элементов массива.

Помогите Решить 4 любые задачи:

1)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Сколько элементов последовательности превышает число 100?
2)Вводится последовательность из 10 вещественных чисел. Вычислить сумму элементов, не превышающих числа А.
3)С клавиатуры вводится последовательность из 7 целых чисел. Определить каких чисел больше: четных или нечетных.
4)С клавиатуры вводится последовательность из 9 чисел. Найти разность между макимальным и минимальным элементами.
5)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер отрицательного элемента, если считать элементы справа. В случае нескольких отрицательных элементов вывести номер последнего из них (т.е. самого правого).
6)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти порядковый номер первого двузначного элемента последовательности, считая элементы в прямом порядке.
7)С клавиатуры вводится последовательность положительных чисел, оканчивающаяся 0. Найти сумму двузначных элементов последовательности.
8)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти произведение отрицательных элементов последовательности.
9)С клавиатуры вводится последовательность чисел, оканчивающаяся 0. Найти в ней минимальный элемент.
10)С клавиатуры вводятся числа 2, 5 или 10, означающие удаления игроков на соответствующее кол-во минут. Условно положительные значения означают удаления в команде А, а отрицательные - в команде В. Для завершения ввода данных используется 0. Сколько всего штрафного времени заработано командами А и В отдельно, а также определить общее штрафное время.

1). Дан массив из n элементов (n >= 4). Подсчитать среднюю арифметическую второго и предпоследнего элемента массива.

2). Дан массив из n элементов. Написать программу подсчитывающую произведение элементов массива.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.



Вы находитесь на странице вопроса "Помогите решить задачу на Кумире: Дан массив. Напечатать все элементы, не превышающие числа 100. Заранее благодарен)))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.