Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Где здесь ошибка?

5-9 класс

program abc;
var a: array of integer;
begin
a[0] := 2;

Dothis 24 февр. 2016 г., 8:05:58 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vlad5klass
24 февр. 2016 г., 9:31:37 (8 лет назад)

type mass = array of integer;
var  a: mass;

+ 0 -
Neznaica
24 февр. 2016 г., 11:08:28 (8 лет назад)

число элементов в массиве не обозначено

+ 0 -
пак2000
24 февр. 2016 г., 12:20:35 (8 лет назад)

Это динамический массив

Ответить

Другие вопросы из категории

Помогите плиииз. Контрошка по информатике а уже скоро конец урока .

Учебник по информатике, набранный на компьютере, содержит 256 страниц, на каждой странице 40 строк, в каждой строке 60 символов. Для кодирования символов используется кодировка КОИ-8, при которой каждый символ кодируется 8 битами. Определите информационный объём учебника.1) 100 байт
2) 200 Кбайт
3) 600 Кбайт
4) 1200 байт
Заранее спасибо)

На одной улице стоят в ряд 4 дома, в каждом из них живет по одному человеку. Их зовут Василий, Семен, Геннадий и Иван. Известно, что все они имеют разные

профессии: скрипач, столяр, охотник и врач. Известно, что:
1.Столяр живет правее охотника,
2.врач живет левее охотника
3. Скрипач живет с краю
4.скрипач живет рядом с врачем
5.Семен не скрипач и не живет рядом со скрипачом
6.Иван живет рядом с охотником
7.Василий живет правее врача
8.Василий живет через дом от Ивана

Определите, кто кем работает и где живет

необхадимо оформить несколько дакументов . запишите какие возможности тестовых процессоров вы будете использовать в каждом из них ( 1)маркированный

список ,2) нумерованный список ,3) таблица , 4) многоуровневый нумерованный список ,5) многоуровневый маркированый списо )

а)расписание уроков на неделю для восьмых классов

б)список учителей школы с указанием предметов , который они ведут

в ) список учеников 8Б класса

г) список покупок в магазине

д)список неуспевающих студентов с указанием предметов , по которым у них имеются долгт

Читайте также

Program Temperature;

var T: array[1..12] of real;
I: integer; Tsred: real;
begin
for I:=1 to 12 do
begin
write('T[', I:2,']= ');
read (T[I])
end;
Tsred:=0;
for I:=1 to 12 do
Tsred:=Tsred+T[I];
Tsred:=Tsred/12;
writeln( 'Среднегодовая температура = ', Tsred:6:2, ' градусов');
for I:=l to 12 do
begin
Dt[I]:= T[I] - Tsred;
writeln('Dt[',I:2,']=', Dt[I]:6:2)
end.
Где здесь ошибка??? Пишет ожидался оператор.

Помогите отредактировать программу - Паскаль. Где-то ошибка.

Необходимо удалить первый кратный 3 элемент массива.
program udalenie;
var i,n,k:integer;
a:array[1..1000] of integer;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
while i<=n do
if a[i] mod 3=0 then
begin
for i:=k to n-1 do
a[i]:=a[i+1];
n:=n-1; exit;
end;
for i:=1 to n do write(a[i],' ');
close (input);
close (output);
end.

пожалуйста помогите очень надо!!! В массиве храниться информация о стоимости товаров. Составьте программу, которая определяет стоимость самого

дешевого(дорогого) товара и его индекс.

вот программа но в ней где-то ошибка

program xxx;

var a:array [1..10] of integer;

i, max, min:integer;

begin

for i:=1 to 10 do read(a[i]);

min:=1;

for i:=2 to 10 do

if a[i]<min then min:=a[i];

writeln('a[',i,']=',a[i]);

max:=a[i];

for i:=2 to 10 do

if a[i]>max then max:=a[i];

writeln('a[',i,']=',a[i]);

end.



Вы находитесь на странице вопроса "Где здесь ошибка?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.