Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Информатики, помогите составить программу, складывающую предложенные числа так, чтобы получилось круглое число от 100 до 1000 на языке pascal.

10-11 класс

гуляев228 16 июня 2016 г., 3:32:23 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tatyankaiazare
16 июня 2016 г., 6:30:52 (7 лет назад)

var
  x, y, z: integer;
begin
  writeln('-1 - конец ввода и вывод суммы');
  repeat
    readln(y);
    
    if (y < -1) then 
      writeln('Эм... Не, не съем: отрицательная цЫфра.')
    else
      if (y >= 0) then 
        z := z + y
      else
        if (y = -1) then
          if (z >= 100) then
            break
          else
            writeln('Не, не годится, прибавь ещё чуток, до сотни не дотягивает');
 
    if (z > 1000) then
    begin
      writeln('Всё, перевес. Сумма чисел больше 1000.');
      exit;
    end;
    
    until (false);
  writeln('Сумма примерно равна (если округлить) ', round(z / 10) * 10);
end.

+ 0 -
Настасия13051997
16 июня 2016 г., 7:06:23 (7 лет назад)

Комментарий удален

+ 0 -
Kirillosik555
16 июня 2016 г., 8:25:09 (7 лет назад)

Комментарий удален

+ 0 -
Chupakhinnik
16 июня 2016 г., 9:20:42 (7 лет назад)

Ну уж извините, я ещё учусь, я всего лишь попросила о помощи, не стоит меня осуждать) никто вас не заставляет помогать

+ 0 -
Worldstes
16 июня 2016 г., 11:30:25 (7 лет назад)

Комментарий удален

+ 0 -
Ivanbel12
16 июня 2016 г., 12:42:57 (7 лет назад)

Хорошо, спасибо за попытку, я уже разобралась. Хорошего дня:)

Ответить

Другие вопросы из категории

Заполнить массив из 10 элементов случайными числами в интервале [-8;13] [-10;25] [98;101] [-5;15] и найти в нем максимальный и минимальный элементы и

их номера.

Пример: Исходный массив: 4 -5 3 10 -4 -6 8 -10 1 0

максимальный a[4]=10

минимальный a[8]=-10

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Qbasic помогите составить программу

Напишите программу, запрашивающую у пользователя три разных целых положительных числа и находящую сумму двух меньших из них

Составить приложение на языке Pascal. Вычислить на ПК значения функции, заданной в таблице. На печать

вывести значения вводимых исходных данных и полученные результаты,
сопровождая их именами переменных. Значения аргумента взять из
указанного диапазона так, чтобы протестировать все ветви программы.



Вы находитесь на странице вопроса "Информатики, помогите составить программу, складывающую предложенные числа так, чтобы получилось круглое число от 100 до 1000 на языке pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.