Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Паскаль.Дано двузначное число m и некоторое число k.Определить равна ли сумма цифр числа m числу k

5-9 класс

Los198300 12 апр. 2013 г., 15:50:44 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krasotka111111
12 апр. 2013 г., 16:39:57 (11 лет назад)

Program qq;
uses crt;
var
m,k,a,b,d,c:integer;
begin
readln(m,k);
a:=m mod 10;
b:= (m div 10) mod 10;
c:=(m div 10) div 10;
d:=a+b+c;
if k=d then Writeln('Да') else Writeln('Нет');
Readkey;
End.

Ответить

Другие вопросы из категории

С клавиатуры вводится матрица вещественных чисел размером N на M. N не превосходит 10, M не превосходит 20. Найти и вывести номер первой строки, в которой

все элементы нулевые. Если элементов удовлетворяющих условию нет, вывести соответствующее сообщение

Будьте добры, помогите пожалуйста.

В ячейке Е4 находится формула СУММ(А4:D4). Куда она переместится и как изменится при:
а) удалении строки 2;
б) удалении строки 7;
в) вставке пустой строки перед строкой 4;
г) удалении столбца 3;
д) вставке пустого столбца перед столбцом 6.

Читайте также

Напишите программу, которая вводит число, не превышающее 45,

и определяет, изменяется ли сумма цифр этого числа при умножении его
на два. Ответ прикрепите в виде файла в среде PascalABC.

Составьте программу,которая определяет,является ли сумма цифр введенного целого трехзначного числа четным числом.

Пример ввода:567.
Пример вывода:сумма цифр числа 567-четное число

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

помогите пожалуйста. 1) Дано слово.Заменить каждый "нечетный" символ на пробел. 2)Дана символьная строка. Определить какая буква встречается

раньше: "x" или "e" ? 3) Дана символьная строка . Определить будет ли произведение цифр нечетным числом?



Вы находитесь на странице вопроса "Паскаль.Дано двузначное число m и некоторое число k.Определить равна ли сумма цифр числа m числу k", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.