Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В классе X детей (2<=Х<=30) сколько может быть различных вариантов формирования пар детей, сидящих за одной партой? Написать

10-11 класс

программу

алинка555алинка 15 мая 2015 г., 6:50:21 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Cococore3
15 мая 2015 г., 7:35:18 (8 лет назад)

Составь факториал из количества мальчиков и девочек (соотношение вероятного количества полов), если не известно, то делаешь так: !30 - !2.

Затем перебираешь все возможные комбинации, можно и при подсчёте факториала записать в массив, потом перебирать. 

Комбинации 2-х человек за одной партой можно составить очень просто: возьми [!30 - !2] -мерный массив, в каждый записывай комбинации (можно просто бинарной системой воспользоваться - 0=девочка, 1=мальчик)

Ответить

Другие вопросы из категории

Даны

две логические функции, зависящие от трех аргументов A, B и C.

Задача на логику.

В пакете лежат фрукты. Все, кроме двух, персики. Все, кроме двух, яблоки. Все, кроме двух, груши. Сколько фруктов в пакете? Каких?

Читайте также

Ввести с клавиатуры три числа (x,y,z). Если x<y<z, то все числа удвоить.

Если z<y<x, то максимальное число возвести в квадрат. Если числа не
удовлетворяют ни одному из условий – обнулить их.

Ребята,помогите добавить цикл.который будет генерировать случайные числа,с помощью команды srand.

Эта программа определяет,возрастающая или убывающая последовательность чисел.

если возрастает,например 1234(1 < 2 < 3 <4 )-то пишет 1
если убывает 321 или 231(3 < 2 < 1)-ложь,пишет ноль
если 111(1 < 1 < 1)ложь,тк строгая возрастающая последовательность,пишет ноль


#include <iostream>
int main()
{
int n;
bool flag = true;
std::cin >> n;
while(n != 0)
{
while (n >= 10)
{
if(n / 10 % 10 >= n % 10)
flag = false;
n = n / 10;
}
std::cout << flag << std::endl;
flag = true;
std::cin >> n;
}
}

Помогите написать задачу на языке Паскаль:

Даны действительные числа a, b, c, d. Если a<b<c<d, то каждое число заменить наибольшим из них. Если a>b>c>d, то каждое число заменить средним арифметическим всех значений. В противном случае все числа заменяются своими квадратами

25 баллов инфа?

Муниципальный этап олимпиады по информатике проводился для учеников
7–11-х классов. Все ученики участвовали в общем конкурсе. Каждый
участник олимпиады мог набрать от 0 до 400 баллов. По положению об
олимпиаде победителем признаётся участник, набравший наибольшее
количество баллов, при условии, что им набрано больше половины
возможных баллов. Победителей может быть несколько, если это количество
баллов наберут несколько человек; а может и не быть совсем, если никто не
наберёт больше половины.
Напишите эффективную по времени работы и по используемой памяти
программу (укажите используемую версию языка программирования,
например Borland Pascal 7.0), которая будет определять фамилию и имя
лучшего участника, не ставшего победителем олимпиады. Если следующий
за баллом победителей один и тот же балл набрали несколько человек или
если победителей нет, а лучших участников несколько (в этом случае они же
являются искомыми), то должно выдаваться только число искомых
участников. Гарантируется, что искомые участники (участник) имеются.
На вход программе сначала подаётся число участников олимпиады N
(N<10000).
В каждой из следующих N строк находится результат одного из участников
олимпиады в следующем формате:
<Фамилия> <Имя> <класс> <баллы>,
где <Фамилия> – строка, состоящая не более чем из 20 непробельных
символов; <Имя> – строка, состоящая не более чем из 15 непробельных
символов; <класс> – число от 7 до 11; <баллы> – целое число от 0 до 400
набранных участником баллов. <Фамилия> и <Имя>, <Имя> и <класс>,
а также <класс> и <баллы> разделены одним пробелом. Пример входной
строки:
Иванов Пётр 10 275
Программа должна выводить через пробел Фамилию и Имя искомого
участника или их число. Пример выходных данных:
Кузнецов Иван
Второй вариант выходных данных:
4

Составить программу вычисления функции на языке паскаль (a+b)/ (e^-x+Sin(x)) T={ (a+b)/(x+1) e^-x+Sin(x) условие:

x<2.8; 2.8<=x<6; x>=6 исходные данные: a=2.1; b=-0.29 шаг изменения: x принадлежит [0;7]; дельта x=0.5



Вы находитесь на странице вопроса "В классе X детей (2&lt;=Х&lt;=30) сколько может быть различных вариантов формирования пар детей, сидящих за одной партой? Написать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.