Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста. Написать программу вычисления суммы цифр числа

10-11 класс

Usolkina 02 авг. 2014 г., 17:14:49 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sendeff123
02 авг. 2014 г., 18:01:12 (9 лет назад)

program znanija;

var

Num, Summ:word;

begin

Summ:=0;

readln(Num);  

repeat  

Summ:=Summ+Num mod 10;  

Num:=Num div 10;

until Num=0;

writeln('Сумма равна - ', Summ);

readln;

end.

Ответить

Другие вопросы из категории

В студии при двухканальной (стерео) звукозаписи с 32-битнымразрешением за 150 секунд был записан звуковой файл. Сжатие данных непроизводилось. Известно,

что размер файла оказался не менее17 и не более19 Мбайт. С какой частотой дискретизации велась запись?

Читайте также

1) Написать программу для вычисления суммы цифр пятизначного числа , введенного с клавиатура

2) Заданы действительные числа a , b , c и d . Написать программу нахождения полусуммы наименьшего и наибольшего из них.
3) Написать программу для вычисления суммы цифр числа , введенного с клавиатуры

Помогите прошу

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N

Всем привет! Помогите пожалуйста по информатике. Задача: ввести целое число и найти сумму его цифр. Пример: введите целое число:1234. Сумма цифр числа 1

234 равна 10. Задача: сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры. Пример: введите целое число 1234 нет введите целое число 1224 да



Вы находитесь на странице вопроса "Помогите пожалуйста. Написать программу вычисления суммы цифр числа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.