Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано натуральное число n. Выбросить из записи числа n цифры 0 и 5, оставив прежним порядок остальных цифр. Например, из числа 59015509 должно получится

10-11 класс

919

Galinaprocyk 29 апр. 2014 г., 13:12:10 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dashynchik
29 апр. 2014 г., 15:45:41 (10 лет назад)

Как то так

 

 

 

program pr;
uses crt;


Var i,n,a,s:integer;

Begin

Writeln('Введите. n');
readln(n);
i:=1;
s:=0;
While n<>0 do
Begin
a:=n mod 10;
if (a<>0) and (a<>5) then
Begin
      s:=s+a*i;
      i:=i*10;
end;
n:=n div 10;
end;

Writeln(s);

end.

Ответить

Другие вопросы из категории

Около стены наклонно стоит палка длиной x м. Один ее конец находится на расстоянии y м от стены. Определить значение угла между палкой и полом для

значений x=k м и y, изменяющегося от 2 до 3 метров с шагом h м. (решить в паскале ,цикл с параметром.Помогите )

Написать программу для решения следующей задачи:

Имеется массив чисел, вводимый с клавиатуры. Вычислить сумму и произведение
всех чисел массива. Результаты вывести на экран. Язык c++. Спасибо.

Пожалуйста,помогите

Спецификация программного продукта..
1.создается заказчиком
2.описывается на этапе разработки программного продукта
3.описывает внутреннюю организацию данного продукта
4.описывает внешнее поведение программного продукта

Читайте также

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Дано натуральное число N. Найти наименьшее число М (N < M < 2N) которое делится на сумму цифр числа N (без остатка). Если такого числа нет, то

вывести слово «нет». Пример. N = 12 345, М = 12360. Число 12 360 делится на число 15 — сумму цифр числа N

Ответьте на вопросы. 1) Какое минимальное основание может иметь система счисления, если в ней записано число 144701? 2) Какое

минимальное основание может иметь система счисления, если в ней записано число A11?



Вы находитесь на странице вопроса "Дано натуральное число n. Выбросить из записи числа n цифры 0 и 5, оставив прежним порядок остальных цифр. Например, из числа 59015509 должно получится", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.