Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите в паскале)) даны координаты вершин прямоугольника А(X1, Y1), B(X2,Y2), C(X3,Y3), D(X4,Y4). Вычислите периметр и площадь прямоугольника.

5-9 класс

містика1998 14 янв. 2015 г., 4:28:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinakylik
14 янв. 2015 г., 5:15:01 (9 лет назад)

var x1,x2,x3,x4,y1,y2,y3,y4:integer;
AB,BC,p,s:real;
begin
read(x1,y1,x2,y2,x3,y3,x4,y4);
AB:=sqrt(sqr(x1-x2)+sqr(y1-y2));
BC:=sqrt(sqr(x2-x3)+sqr(y2-y3));
p:=2*(ab+bc);
s:=ab*bc;
write('p=',p,' s=',s);
end.

+ 0 -
Dae33
14 янв. 2015 г., 7:48:03 (9 лет назад)

program umn;

Ответить

Другие вопросы из категории

Приведите примеры:

Отношение между двумя объектами-......
Отношение между объектом и множеством объектов-.......
Отношение между двумя множествами объектов-........

понятия:достоверная,обьективная,полная,актуальная,понятная-А)достаточная для принятия решения и понимания ситуации ,Б)важная и существенная для настоящего

времени,В)не зависит от чьего либо мнения или суждения,Г)выражения на языке, доступном для получения,Д)отрожает истенное положение тел.

Определить, что будет напечатано в результате выполнения

программы:
a:=10;
b:=5;
a:=a*2 - 3*b;
if a /2 < b then
c:=a /b
else
s:=a+b /5;

Сколько букв и какого алфавита содержит

зашифрованный десятичными кодами текст: 128 32 139 32
148 32 128 32 130 32 136 32 146? Какой объем памяти
занимает данный текст?

Читайте также

Составить программу, которая определяет, являются ли разные точки с координатами (X1,Y1) и (X2, Y2) симметричными относительно осей координат или

начала координат.

прочертить путь выполнения алгоритма для следующих значений параметров:

А) X1= -1, Y1=6, X2=1, Y2=6.

Б) X1=6, Y1=7, X2=1, Y2=6

Вычислите расстояние между двумя точками с данными координатами: (x1,y1) и (x2,y2)

Формула для нахождения расстояния: картинка снизу
И всё это в паскаль. Спасибо.

1)

Решить в паскале:Дан массив количества продаж телевизоров,получить количество телевизоров проданных за неделю (количество телевизоров в день взять любое число)


2)

С1. Составить алгоритм

и написать программу на вычисление площади или периметра прямоугольника
, при условии, если а < b ,
тогда вычисляем периметр , иначе площадь . Каждую строку программы прокомментировать .
Входные данные а=10 , b=8
помогите решить 9 класс

Решить пользуясь алгоритмами и программой паскаль:

1) В прямоугольнике известны стороны а и b,вычислите периметр и площадь.
2) Известно число а, число b в два раза больше. А число с на 3 раза меньше, чем сумма первых двух.



Вы находитесь на странице вопроса "Решите в паскале)) даны координаты вершин прямоугольника А(X1, Y1), B(X2,Y2), C(X3,Y3), D(X4,Y4). Вычислите периметр и площадь прямоугольника.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.