Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите пожалуйста! с клавиатуры вводятся 10 двузначных чисел. Напечатать те из них, которые делятся нацело на 4, но не делятся на 6. подсчитать их

10-11 класс

количество.

Дашулиста 01 авг. 2013 г., 6:20:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alinka040296
01 авг. 2013 г., 9:00:12 (10 лет назад)

const

  n = 10; //Количество чисел, которое нужно ввести
var
  a: array [1..n] of 10..99; {Массив двузначных чисел, которые вводятся с клавиатуры}
  number, i: integer; //number - количество чисел

begin
  number:= 0; //Обнуляем счетчик
  for i:= 1 to n do //Вводим n двузначных чисел
  begin
    writeln('Введите двузначное число');
    readln(a[i]);
  end;
  write('Числа, которые делятся на 4,но не делятся на 6: ');
  for i:= 1 to n do  {Распечатываем числа, которые делятся на 4, но не делятся на 6}
    if (a[i] mod 4 = 0) and (a[i] mod 6 <>0) then {если число делится на 4 и не делится на 6, прибавляем к счетчику 1}
  begin
    write(a[i], ' ');
    number:= number + 1;
  end;
  writeln;
  writeln('Количество чисел, которые делятся на 4, но не делятся на 6: ', number);
end.

Ответить

Другие вопросы из категории

На бейсике Даны массивы A(m) и B(m), m<=12 Сформулировать массив С по правилу: C1=Bm+A1 C2=Bm-1+A2

------------

Cm=B1+Am

Найти сумму S элементов массива С. Вывести на печать массивы A,B,C и полученную сумму S..

СРОЧНО! 1 ЗАДАЧА ПО ИНФОРМАТИКЕ!

Дан массив из 12 элементов. Найти количество элементов массива по абсолютной величине больших 15.

Читайте также

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.

Найти сумму двузначных нечетных чисел. Вывести сумму. А также выводить на экран сколько вводилось двузначных чисел и сколько из них

было нечетных. То есть всего должно быть 3 вывода. Помогите пожалуйста!



Вы находитесь на странице вопроса "Помогите пожалуйста! с клавиатуры вводятся 10 двузначных чисел. Напечатать те из них, которые делятся нацело на 4, но не делятся на 6. подсчитать их", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.