Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

А вот с этим не поможете где тут ошибка???

10-11 класс

Задан
двумерный вещественный массив размерности
N*M (N строк,
M столбцов). 0≤N≤5, 0≤M≤5.
Найти наибольший и наименьший элемент
в массиве.

Танька3hrte 28 апр. 2014 г., 19:06:34 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sherf1983
28 апр. 2014 г., 21:29:16 (10 лет назад)

var a:array[1..5, 1..5] of real;
i,j,n,m:integer;
max,min:real;
begin
write('Введите число n в промежутке от 0 до 5:');
readln(n);
write('Введите число m в промежутке от 0 до 5:');
readln(m);
for i:=1 to n do
begin
for j:=1 to m do
begin
readln(a[i,j]);
end;
max:=a[1,1];
min:=a[1,1];
end;
for i:=1 to n do
beginf
or j:=1 to m do
begin
if a[i,j]>max then max:=a[i,j];
if a[i,j]<min then min:=a[i,j];
end;
end;
writeln('Наибольший элемент массива: ',max);
writeln('Наименьший элемент массива: ',min);
end.
P.S.Вот полностью верная программа,на основе вашей программы.Ошибки можете увидеть сами(различия)

+ 0 -
Namysbaev
28 апр. 2014 г., 23:28:18 (10 лет назад)

Переделанная программа во вложениях, Удачи. 

Ответить

Другие вопросы из категории

Написать программу в free pascal дан массив из 10элеметов найти

А)сумму элементов массива
Б)количество отрицательных элеметов
В)вывести номера элементов массива кратных 3

Помогите пожалуйста решить.
Помогите пожалуйста!

Ввести

Читайте также

1.Среди цифр четырехзначного числа есть четная. Накидал тут решение, но где-то ошибка, не могу

понять где

var
t,s,d,e,i: integer;
begin
for i:= 1000 to 9999 do
t:=i div 1000;
s:=(i div 100)mod 10 ;
d:=(i div 10) mod 10;
e:=i mod 10;
if ((t mod 2=0) or (s mod 2 =0) or (d mod 2 =0) or (e mod 2=0)) then writeln ('TRUE') else writeln ('FALSE');
end.

«Технология обработки числовой информации» Excel Вопрос 1. ЭТ – это 1)Прикладная программа, предназначенная

для обработки структурированных в виде таблицы данных

2)Прикладная программа для обработки кодовых таблиц

3)Устройство ПК, управляющее его ресурсами в процессе обработки табличных данных

4)Системная программа, управляющая обработкой табличных данных

Вопрос 2. ЭТ предназначена для

1)обработки числовых данных, представленных в виде таблиц

2)упорядоченного хранения и обработки значительных массивов данных

3)визуализации структурных связей между данными, представленными в виде таблиц

4)редактирования больших объемов информации

Вопрос 3. ЭТ представляет собой

1)совокупность пронумерованных столбцов и поименованных буквами латинского языка строк

2)совокупность пронумерованных строк и поименованных буквами латинского языка столбцов

3)совокупность пронумерованных строк и столбцов

4)совокупность строк и столбцов

Вопрос 4. Строки ЭТ

1)именуются пользователем произвольным образом

2)обозначаются буквами латинского языка

3)обозначаются буквами русского языка

4)нумеруются

Вопрос 5. Столбцы ЭТ

1)обозначаются буквами русского языка

2)нумеруются

3)обозначаются буквами латинского языка

4)именуются пользователем произвольным образом

Вопрос 6. Для пользователя ячейка ЭТ идентифицируется

1)адресом машинного слова ОП, отведенного под ячейку

2)специальным кодовым словом

3)путем последовательного указания имени столбца и номера строки, на пересечении которых располагается ячейка

4)именем, задаваемым пользователем

Вопрос 7. Вычислительные формулы в ячейках ЭТ записываются

1)в обычной математической записи

2)специальным образом с использованием встроенных функций и по правилам, принятым для записи выражений в языках программирования

3)по правилам, принятым исключительно для электронных таблиц

4)по правилам математики

Вопрос 8. Выражение 3 (А1+В1) : 5 (2В1-3А2), записанное в соответствии с правилами,

принятыми в математике, в ЭТ, имеет вид

1)3* (А1+В1)/(5*(2*В1-3*А2))

2)3(А1+В1)/5*(2В1-3А2)

3)3(А1+В1)/(5*(2В1-3А2))

4)3*(А1+В1)/5*(2*В1-3*А2)

Вопрос 9. Среди приведенных отыщите формулу для ЭТ

1)А3В8+12

2)А1=А3*В8+12

3)А3*В8+12

4)=А3*В8+12

Вопрос 10. Запись формулы в ЭТ не может включать в себя

1)знаки арифметических опраций

2)числовые выражения

3)имена ячеек

4)текст

Вопрос 11. При перемещении или копировании в ЭТ абсолютные ссылки

1)не изменяются

2)преобразуются вне зависимости от нового положения формулы

3)преобразуются в зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 12. При перемещении или копировании в ЭТ относительные ссылки

1)преобразуются в зависимости от нового положения формулы

2)не изменяются

3)преобразуются вне зависимости от нового положения формулы

4)преобразуются в зависимости от длины формулы

Вопрос 13. Диапазон - это

1)совокупность клеток, образующих в таблице область прямоугольной формы

2)все ячейки одной строки

3)все ячейки одного столбца

4)множество допустимых значений

Вопрос 14. Активная ячейка - это ячейка

1)для записи формул

2)для записи чисел

3)для записи чисел, формул, текста

4)в которой выполяется ввод данных

Вопрос 15. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=А2*С4

2)=А2*$С$4

3)=$А$2*С4

4)=A4*C4

Вопрос 16. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=A2*5

2)=$A$2*4

3)=A2*$C$4

4)=$A$2*5

Вопрос 17. Какая Формула будет получена при копировании в E4 формулы из Е2?

1)=$А$2*$С$4

2)=A2*$C$2

3)=$А$2*С4

4)=A4*C4

Вопрос 18. Чему будет равно значение в ячейке С1, если в нее ввести формулу =А1+В1?

1)15

2)10

3)20

4)25

Вопрос 19. Чему будет равно значение в ячейке С1, если в нее ввести формулу

=СУММ(А1:В1)*2?

1)10

2)300

3)100

4)30

Вопрос 20. Сортировкой называют

1)процесс поиска наибольшего и наименьшего элементов массива

2)процесс частичного упорядочения некоторого множества

3)любой процесс перестановки

4)процесс линейного упорядочения некоторого множества

program klass; type ocenki=record name:string[15]; marks: array [1..5] of integer; end; var a,k,i:integer;

c:array [1..5] of ocenki;

begin k:=0;

For i:=1 to 5 do

With c[i] do

begin

write('vvedite name'); readln(name);

write('vvedine marks');

for i:=1 to 5 do read(marks[i]);

a:=i;

if c[a].marks < 2 (вот здесь выдает что операнды имеют неприводимые типы) then k:=k+1; writeln(k);

end;

end.

(Подскажите пожалуйста где допустила ошибку)



Вы находитесь на странице вопроса "А вот с этим не поможете где тут ошибка???", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.