Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Даны три числа,найти разность наибольшого числа с наименьшим.(РЕшить с repeat,until)

5-9 класс

Volodyabel 07 нояб. 2014 г., 9:34:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Davidvovano
07 нояб. 2014 г., 11:12:10 (9 лет назад)

const
  n = 3;

var
  m: array[1..n] of integer;
  i, mn, mx: integer;

begin
  Write('Введите через пробел три целых числа: ');
  i := 1;
  repeat
    Read(m[i]);
    i := i + 1
  until i > n;
  mn := m[1];
  mx := mn;
  i := 2;
  repeat
    if mx < m[i] then mx := m[i]
    else
    if mn > m[i] then mn := m[i];
    i := i + 1
  until i > n;
  Writeln('Разность наибольшего с наименьшим равна ', mx - mn)
end.

Тестовое решение:

Введите через пробел три целых числа: 7 9 3
Разность наибольшего с наименьшим равна 6


+ 0 -
Annochateterina
07 нояб. 2014 г., 14:00:40 (9 лет назад)

Зачем тут операторы цикла?

+ 0 -
ПолинаМакарова
07 нояб. 2014 г., 16:38:54 (9 лет назад)

Сказали через цикл решить.Я через ветвление сам сделал.А цикли не понимаю

+ 0 -
KateMart
07 нояб. 2014 г., 17:39:23 (9 лет назад)

может три числа в массив загнать? но это тупо...

Ответить

Другие вопросы из категории

Что не входит в состав аппаратного обеспечения информационной системы?

1.устройства ввода-вывода
2.операционная система
3.запоминающие устройства
4.процессор

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!

1)СЛОВЕСНАЯ МОДЕЛЬ ЖИВОТНЫХ ВСЕХ
ПРОШУ ОЧЕНЬ НАДО ПОМОГИТЕ

Электрическая цепь составлена изЭлектрическая цепь составлена из нескольких сопротивлений. Определите сопротивление между узлами А и Б.

Нужно написать программу в Паскале.
Между А и Б сопротивление
R1, R(общее R2, R3), R4 соединены последовательно, а R2 и R3 параллельно.
Т.е. общее сопротивление равно..
R=R1+(R2*R3)/(R2+R3)+R4
на основании этой формулы нужна программа.

Читайте также

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

Ввести три числа, найти их сумму, произведение и среднее арифметическое

Пример
Введите три числа
4 5 7
4+5+7=16
4×5×7=140
(4+5+7)÷3=5.333333

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.



Вы находитесь на странице вопроса "Даны три числа,найти разность наибольшого числа с наименьшим.(РЕшить с repeat,until)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.