Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан текстовый файл, содержащий только целые числа, состоящий из трёх строк. Определить длину самой меньшей строки.

5-9 класс

Andrej201096 21 авг. 2014 г., 15:30:28 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kirik434
21 авг. 2014 г., 16:58:18 (9 лет назад)

program proga;
var str1,str2,str3:string;
input:Text;
begin
Assign(input,'file.txt');
reset(input);
readln(input,str1);
 readln(input,str2);
 readln(input,str3);
if(length(str1)>length(str3)and length(str3)) then
writeln('1 строка самая длинная');
else if length(str2)>length(str3) and length(str1) then
 writeln('2 строка самая длинная');
 else if length(str3)>length(str1) and length(str2) then
writeln('3 строка самая длинная');
close(input);
end.
P.S файл со строками надо предварительно создать в папке с Exe файлом программы

Ответить

Другие вопросы из категории

Сообщение кодируется последовательностью флажков,поочередно поднимаемых и опускаемых сигнальщиком.Передавая сообщение,сигнальщик поднимал флажки 3

раза.Сколько бит информации содержалось в переданном сообщении,если в набор сигнальщика входило 16 флажков???(С объяснением пожалуйста)

Читайте также

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".

Задано два целых числа A и B. Найдите сумму нечетных чисел от A до B.

Формат входных данных
Первая строка входного файла содержит два целых числа A и B (1 <= A, B <= 10^9).
Формат выходных данных
Выведите ответ к задаче.

1.Дано целое число,лежащее в диапазоне 1-999.Вывести его строку-описание вида "четное двузначное число","нечетное трехзначное число" и т.д.

2.Даны 3 переменные вещественного типа:А,В,С.Если их значения упорядочены по возрастанию,то удвоить их.В противном случае заменить значение каждой переменной на противоположное.Вывести новые значения переменных А,В,С.
3. Даны 3 целых числа,одно из которых отлично от двух других,равных между собой. Определить порядковый номер числа,отличного от остальных.

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

Pascal а)Для заданных целых чисел A и B вывести двучлен Ax+B в корректном виде. Для A, B=0 результатом должен быть 0.

Формат файла входных данных:

Во входном файле заданы два целых числа не превосходящих 32000.


Формат файла выходных данных:

Вывести математически корректное выражение.

б)Самолет взлетает в X (целое, 0<=X<=23) часов по местному времени в часовом поясе номер M (целое, 0<=M<=23). После полета в течение K (целое, 1<=K<=12) часов он приземляется в часовом поясе номер N (целое, 0<=N<=23). Определите местное время в пункте приземления. Считать, что часовые пояса нумеруются с запада на восток.



Формат входных данных:

В первой строке текстового файла через пробел записаны числа X, M, K, N.


Формат выходных данных:

В выходной файл требуется выдать местное время в пункте назначения в часах.

Пример входного файла
20 1 4 1

Пример выходного файла
0

Помогите буду благодарен.



Вы находитесь на странице вопроса "Дан текстовый файл, содержащий только целые числа, состоящий из трёх строк. Определить длину самой меньшей строки.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.