Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводится число n, за ним массив из n целых чисел и число x. Найдите количество элементов массива, значение которых равно x*x.

10-11 класс

Vikt0r1ia 19 авг. 2013 г., 18:45:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Evelinka28
19 авг. 2013 г., 20:00:18 (10 лет назад)

var
a: array [1..100] of integer;
n,i,x,k:integer;
begin
write('n=');
readln(n);
for i:=1 to n do
begin
write('A[',i,']=');
readln(a[i]);
end;
write('x=');
readln(x);
k:=0;
for i:=1 to n do
if a[i]=x*x then
inc(k);
writeln('Количество = ',k);
readln;
end.

Ответить

Другие вопросы из категории

ЗАПРОСЫ SQL 1) создать схему БД для таблиц (Банк, Клиент) 2) Создать структуру таблиц (Банк, Клиент) 1) CREATE SCHEMA

AUTORIZATION . . . . .

2) CREATE TABLE Банк(Код INT NOT NULL, . . . . . .

CREATE TABLE Клиент(Код INT NOT NULL, . . . . . .

Сколько единиц в двоичной записи числа 34,25?
Элемент матрицы назовем седловой точкой,если он является наименьшим в своей строке и одновременно наибольшим в своем столбце или,наоборот,является

наибольшим в своей строке и наименьшим в своем столбце. Для заданной целой матрицы размером n*m напечатать индексы всех ее седловых точек.

Pascal ABC

Вычислить сумму квадратов отрицательных чисел,
стоящих на местах, кратных 3; подсчитать количество чисел, не принадлежащих промежутку [А, В).

Читайте также

Программирование в VBA. Задача:Массив сотоит из двадцати элементов. Сколько элементов массива нужно сложить (начиная с первого), чтобы сумма превысила

число 100. Вот моя программа:

Private Sub CommandButton1_Click()
Dim C(1 To 20) As Integer
Dim I, N, S As Integer
For I = 1 To 20
C(I) = Cells(I, 1)
Next I
S = 0
N = 0
For I = 1 To 20
If S <= 100 Then S = S + C(I) And N = N + 1
Next I
Cells(2, 3) = "Количество элементов массива, сумма которых превышает 100=" & N
End Sub

как результат выводит "0" (т.е. N заданное изначально). Может, кто-то сможет подсказать ошибку? Это срочно!

Выполнить в paskal

N=12 Ввести число К Определить количество элементов массива, значения которых больше K.
...
Все элементы массива увеличить в 3 раза. Массив вывести.
...
Определить максимальное значение сред положительных элементов массива.

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

Дан массив X(N).Найти среднее арифметическое элементов массива,значения которых заключены в интервале [-3;3]. Если эта величина больше

заданного числа Z,то найти сумму четных элементов,иначе- произведение нечетных элементов.

Друзья,очень нужна ваша помощь,пожалуйста,если Вы решили мне помочь-отпишитесь. Заранее спасибо!

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Напишите программу, которая подсчитывает

количество элементов массива равных макс. среди двухзначных чисел. Если ни одного такого числа нет, нужно вывести сообщение об этом.



Вы находитесь на странице вопроса "С клавиатуры вводится число n, за ним массив из n целых чисел и число x. Найдите количество элементов массива, значение которых равно x*x.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.