Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

CРОЧНО!!!!дан массив состоящий из 10 целых чисел требуется найти количество элементов массива равных максимальному элементу и выписать их индексы

10-11 класс

M1zera 30 июня 2016 г., 6:21:30 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
алясбарычь
30 июня 2016 г., 7:17:47 (7 лет назад)

A:Array[1..10] of Integer;
Begin
 for i:=1 to 10 do
  begin
   Read(A[i]);
  end;
 max:=A[1];
 for i:=1 to 10 do
  if (A[i]>max) then max:=A[i];
 for i:=1 to 10 do
  if (A[i]=max) then
   begin
    Inc(k);
    Writeln('index = ',i);
   end;
 Writeln('Kol-vo = ',k);
end.

+ 0 -
Mадина
30 июня 2016 г., 9:38:08 (7 лет назад)

паскаль?

Ответить

Другие вопросы из категории

Как

в лазарусе /делфи сделать в калькуляторе :
arcsin
arccos
arctg
arcctg
n!
%

Напишите программу...........
друзья!9 задачка!)))))))))Помогите!)
два игрока играют в следующую игру. на доске записано число 2 ход состоит в том что текущее число x на доске стирается,а вместо него записывается одно

из трех чисел: x+3; x+5; и 2x. Выигрывает игрок, после хода которого на доске оказывается число. Большее 20. Кто выигрывает при безошибочной игре обоих игроков - начинающий или второй игрок? Ответ обоснуйте

Читайте также

Дан массив, состоящий из 100 целых чисел:

а) Вывести все числа, которые встречаются в этом массиве по нескольку раз;
б) Вывести все числа, которые встречаются в массиве только по одному разу.

Составить блок-схему решения задачи:

Дан массив, состоящий из 10 произвольных чисел. Найти среднее геометрическое этих чисел.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "CРОЧНО!!!!дан массив состоящий из 10 целых чисел требуется найти количество элементов массива равных максимальному элементу и выписать их индексы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.