Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада

5-9 класс

становится больше. Определите, через сколько лет вклад составит не менее y рублей. Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число.

ТатьянаТВ1980 15 февр. 2017 г., 0:13:03 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dkird12
15 февр. 2017 г., 1:36:53 (7 лет назад)

var

  x, y, p, year:integer;

  Summ:real;

begin

  readln(x);

  readln(p);

  readln(y);

  Summ := x;

  year := 0;

  while Summ < y do

  begin

    Summ := (Trunc(Summ * (1 + p / 100) * 100)) / 100;

    year := year + 1;

  end;

  writeln(year);

end.

 

 

// другой вариант

var
  x, y, p, year, Summ:integer;
begin
  readln(x);
  readln(p);
  readln(y);
  Summ := x * 100;
  year := 0;
  while Summ < y * 100 do
  begin
    Summ := Trunc(Summ * (1 + p / 100));
    year := year + 1;
  end;
  writeln(year);
end.

Ответить

Читайте также

помогите!! ГРАЖДАНИН 1 МАРТА ОТКРЫЛ СЧЕТ В БАНКЕ, ВЛОЖИВ 1000 РУБЛЕЙ. ЧЕРЕЗ КАЖДЫЙ МЕСЯЦ РАЗМЕР ВКЛАДА УВЕЛИЧИВАЛСЯ НА 2 ПРОЦЕНТА ОТ ИМЕЮЩЕЙСЯ

СУММЫ. ОПРЕДЕЛИТЬ ЧЕРЕЗ СКОЛЬКО МЕСЯЦЕВ, РАЗМЕР ВКЛАДА ПРИВЫСИТ 1200 РУБЛЕЙ.

Нужно полностью решение в паскале.

Задача: Начальный вклад в банке равен 1000 рублей. Через каждый месяц размер вклада увеличивается на 5%. Через сколько месяцев размер вклада превысит 1100 рублей?

Начав тренировки спортсмен в первый день пробежал 10 км .

Каждый день он увеличивал на 10% норму от предыдущего дня.

Какой суммарный путь он пробежит за 7 дней?


Надо составить алгоритм





Вы находитесь на странице вопроса "Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.