Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Ребята играют в игру на отгадывание числа.Правила такие-ведущий загадывет число не больше 1000 остальные по очереди говорят любое число и какое

5-9 класс

минимальное количество вопросов должны задать ребята чтобы в самом худшоем случии выйграть в такой игре ?

Инкогнито2000 02 нояб. 2013 г., 1:15:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinshherbakov
02 нояб. 2013 г., 2:18:23 (10 лет назад)

максимально можно задать 10 вопросов
сначала a и b обозначим отрезок от 1 до 1000
потом в c найдем середину отрезка a и b
после чего задаем вопрос:
больше с?
если больше то a приравняем c
если меньше то b приравняем a
то есть другими словами 1000 делим на 2 столько раз пока она не будет меньше или равно 1

Ответить

Другие вопросы из категории

в лыжной гонке участвуют 119 спортсменов. Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая

номер участника цепочкой из нулей и единиц минимальной длины, одинаковой для каждого спортсмена. Каков будет информационный объём сообщения, записанного устройством, после того как промежуточный финиш пройдет половины лыжников?

Читайте также

ПОМОГИТЕ В ЧЕМ ОШИБКА!!

program ZADACHA1;

var
a,b,c,d,d1,e:integer;
x,y,k,l:real;

begin
WRITELN('Цыбулак Максим');
READLN(a);
READLN(b);
c:=a+b;
e:=a*b;
d:=a-b;
k:=a/b;
d1:=b-a;
l:=b/a;
WRITELN('a+b=',c);
WRITELN('a-b=',d);
WRITELN('b-a=',d1);
WRITELN('a*b=',e);
WRITELN('a/b=',k);
WRITELN('b/a=',l);
m;=SQR(a);
n;=SQR(b);
o;=SQRT(a);
p;=SQRT(b);
WRITELN('квадрат числа',a,'=',m);
WRITELN('квадрат числа',b,'=',n);
WRITELN('корень числа',a,'=',o);
WRITELN('корень числа',b,'=',p);
end.

1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игрок

может добавить в кучу 1 или 2 камня или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 17 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 24. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 24 или больше камней.
В начальный момент в куче было S камней, 1 ≤ S ≤ 23.
1. При каких S: 1а) Петя выигрывает первым ходом; 1б) Ваня выигрывает первым ходом?
2. Назовите 2 значения S, при которых Петя может выиграть своим вторым ходом?
3. При каком S Ваня выигрывает своим первым или вторым ходом?

Составьте программу, которая получает на вход с клавиатуры три различных целых числа a,b,c (каждое число – с новой

строки) и выводит на экран сумму максимального и следующего за ним по величине числа. Каждое число по абсолютной величине не превышает 10 000.



Вы находитесь на странице вопроса "Ребята играют в игру на отгадывание числа.Правила такие-ведущий загадывет число не больше 1000 остальные по очереди говорят любое число и какое", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.