Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

составить программу массива из первых n натуральных чисел ( n задается с клавиатуры) и вычислить суммы четных элементов

10-11 класс

Бокова 02 марта 2014 г., 2:11:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dobryykirya
02 марта 2014 г., 4:39:34 (10 лет назад)

Program z2; 
var a:array[1..100] of integer; 
i,s: integer; 
begin
for i:=1 to 10 do readln(a[i]);
for i:=1 to 10 do
if a[i] mod 2=0 then s:=s+a[i];
write('Сумма всех нечётных элементов: ',s);
end.

+ 0 -
Companyproduction
02 марта 2014 г., 6:55:11 (10 лет назад)

Program enot;
 var a:array[1..999] of integer; 
i,sum,n: integer; 
begin
read(n);
for i:=1 to n do
a[i]:= i;
for i:=1 to n do
if a[i] mod 2=0 then sum:=sum+a[i];
write('Сумма: ',sum);
end.

Ответить

Другие вопросы из категории

Привет, решите пожалуйста задачу в pascal abc

Смотрим фотку!
Спасибо заранее!

Ребятки, помогите пожалуйста! Нужно решить задачку с помощью программирования языка Паскаля

Найдите любое трёхзначное число, кратное заданному P и не равное ему.

Читайте также

Составить программу в СИ:

1) Составить программу, проверяющую, является ли заданное натуральное число совершенным, то есть равным сумме своих положительных делителей, кроме самого этого числа.
2) Напечатать числа в виде следующей таблицы:
5 5 5 5 5
6 6 6 6
7 7 7
8 8
9

1.Дан целочисленный массив X(N). Найти сумму четных элементов массива .Если эта сумма больше заданного числа Z , то у элементов , расположенных на

нечетных местах , сменить знак на противоположный ,иначе выдать соответствующее сообщение.

2.Дан массив X(N,M) . Среди четных столбцов массива найти сумму положительных элементов

3.Найти произведение элементов каждого столбца массива принадлежащих промежутку [2,6] . Из полученных значений сформировать одномерный массив.



Вы находитесь на странице вопроса "составить программу массива из первых n натуральных чисел ( n задается с клавиатуры) и вычислить суммы четных элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.