Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

1.Напишите класс, который принимает с клавиатуры двузначное число и проверяет, что больше: само это число или произведение его цифр.

10-11 класс

Nata873 18 сент. 2014 г., 18:18:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dzimperka
18 сент. 2014 г., 20:15:09 (9 лет назад)

uses crt;
var a:integer;
begin
clrscr;
if a> ((a mod 10) * (a div 10)) then writeln('A bolshe') else
if a< ((a mod 10) * (a div 10)) then writeln('Proizvedeniye bolshe') else
writeln('Ravni');

end.

Ответить

Другие вопросы из категории

Читайте также

Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было

введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от 0 до 100. Напишите программу, которая позволит найти сумму

двузначных элементов массива, которые не оканчиваются на 3. №2. Дан массив из 100 элементов. Каждый элемент может принимать целочисленные значения от 1 до 500. Напишите программу, которая позволит найти и вывести минимальное значение среди элементов массива, которые делят максимальное значение элементов массива без остатка.



Вы находитесь на странице вопроса "1.Напишите класс, который принимает с клавиатуры двузначное число и проверяет, что больше: само это число или произведение его цифр.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.