Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите решить задачу,завтра экз...пжл** Тоже массивом. Найти максимальный четный элемент массива и его номер при условии, что все элементы

10-11 класс

различные.

составить программу

Igor050403 10 авг. 2016 г., 10:00:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89273
10 авг. 2016 г., 12:20:57 (7 лет назад)

Program n1;
Uses CRT;
Const n=10;
Var a: array[1..n] of integer;
i,max,k: integer;
begin
ClrScr;
Randomize;
For i:=1 to n do
begin
a[i]:=random(50);
write(a[i]:3);
end;
For i:=1 to n do
If a[i] mod 2=0 then
If a[i]>max then
begin
max:=a[i];
k:=i;
end;
writeln;
Writeln('Элемент ',max,' с номером ',k);
readln
end.

Ответить

Другие вопросы из категории

помогите, пожалуйста. ИНФОРМАТИКА

1.Для хранения изображения размером 1544*2080 используется примерно 2,75 Мбайта. Определите глубину цвета данного изображения.

В терминологии сетей TCP/IP маской сети называется двоичное число, определяющее, какая часть IP-адреса узла сети относится к адресу сети, а какая – к

адресу самого узла в этой сети. Обычно маска записывается по тем же правилам, что и IP-адрес. Адрес сети получается в результате применения поразрядно конъюнкции к заданному IP-адресу узла и маске. По заданным IP-адресу узла и маске определите адрес сети. IP-адрес узла : 224.120.249.18 Маска: 225.225.240.0 При записи ответа выберите из приведённых в таблице чисел четыре элемента IP-адреса сети и запишите в нужном порядке соответствующие им буквы, без использования точек. A=0, B=19, C=120, D=208, E=224, F=240, G=248, H=255

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему. Дан одномерный массив А состоящий из 10

элементов.Вывести на экран исходную таблицу и резултат программы.

Найти произведения элементов массива А. удовлетворяющих условию:

c<=A[i]<=d.

Помогите решить, пожалуйста! Хотя бы некоторые задачи.

1. Найти сумму (произведение) элементов 1-й строки (столбца) массива Т (6,4).
2. Заполните матрицу, элементами которой является произведение номеров строк и столбцов соответствующих элементов.
3. Вычислить сумму и произведения элементов матрицы Z (4,6).
4. Вычислить сумму и произведение элементов матрицы А(5,5).
Язык программирования - Pascal.

Пожалуйста,помогите решить задачи на Pascale!

1)Составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100
2)Записать в файл последовательность доступа n действительных чисел. Найти разность первого и последнего компонентов файла
3)Составить программу, удаляющую из предложения букву "Е"

Помогите решить задачи по паскалю:

1. модифицируйте предыдущий пример, так чтобы программа определяла максимальный и минимальный элемент массива
2. Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (вещественная величина типа real)
Начало:
var a: array[1..10] of integer;
i: integer;
begin
а как дальше?

Предыдущий пример:
var a: array[1..10] of integer;
i: integer;
begin
randomize;
for i:=1 to 10 do
begina[i]:=random(40)-20;
end;
for i:=1write(a[i]:4);
end.



Вы находитесь на странице вопроса "помогите решить задачу,завтра экз...пжл** Тоже массивом. Найти максимальный четный элемент массива и его номер при условии, что все элементы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.