Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Ввести с клавиатуры натуральное число N, не превосходящее 10^9. Вывести все простые

10-11 класс

числа из диапазона [1..N].

Maleevvladislav 28 авг. 2014 г., 7:45:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vitaly44
28 авг. 2014 г., 8:25:43 (9 лет назад)

Var
N,i:integer;
begin
writeln('Введите число');
readln(N);
for i:= 1 to n do
write(i,' ');
end.

Ответить

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

НАПИСАТЬ ПРОГРАММУ!ПОМОГИТЕ!!!

while и repeat
1)напечатать все отрицательные числа из диапазона от а до б, с шагом h.
2)Напишите программу, при выполнении которой с клавиатуры считывается натуральное число N, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

Требуется подсчитать, на сколько минут раньше будет заканчиваться k-й урок, если все перемены сократить на 5 минут.

Формат входных данных: Вводится одно натуральное число k, не превосходящее 7.

составить программу в паскале.

Формат ввода:
вводится одно натуральное число N, не превосходящее 50.
Формат ввода:
Выведите 1,если данное число просто и 0, в противном случае.



Вы находитесь на странице вопроса "Ввести с клавиатуры натуральное число N, не превосходящее 10^9. Вывести все простые", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.