Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет.

5-9 класс

Шура2012 07 мая 2013 г., 3:55:53 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Жеканик
07 мая 2013 г., 4:45:50 (10 лет назад)

program gt;
var s,q,n:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
writeln(s);
if(n mod 2=0)then writeln('четное')else writeln('не четное');
end.

Ответить

Другие вопросы из категории

фирма электронные приборы выпустила автоматизированную ванну "Банный комплекс - 21 века ,, . Однако в результате ошибки фирмы все кнопки , кроме ,,

Долить 5 л" и ,, Слить 3 л ,, Не работают . Напишите программу , позволяющую долить в ванну 3 л воды . Сколько воды пропало впустию из-за брака фирмы ?

Занести данные в таблицу

1 . Команда 2 . Результат

Какую фигуру нарисует черепашка .Считайте что в начале она смотрит вверх.

а)по вперёд 40 налево 45 назад 30 направо 90 вперёд 30 налево 45 назад 40 пп домой.
б) по налево 30 вперёд 80 налево 60 назад 40 налево 60 вперёд 80 направо 60 назад 40 пп домой.
в) по вперёд 60 направо 120 вперёд 60 направо 120 вперёд 60 пп домой.

Можете объяснить суть данной программы? Не понимаю как она работает. Желательно каждую строчку расписать.

Procedure P(x, y: integer; var z : integer);
Begin y:=y - x;
z:=y*(y+x);
End;
Var a,b,c:integer;
Begin
a:=15; b:=25; c:=10;
P( a,b,c);
Writeln(a,’ ‘,b,’ ‘,c);
End.

Читайте также

Ребята,помогите пожалуйста!!!))) суть задания: Составьте блок-схему и программу на языке VBA, которая вычисляет сумму первых n целых положительных четных

чисел. Количество суммируемых
чисел должно вводиться во время работы программы. Программа должна
проверять правильность введенных пользователем данных и, если они неверные ( n ≤ 0 ), выдавать сообщение об ошибке.
Буду очень признательна, если кто-нибудь возьмется за это задание. Спасибо)

написать программу(на ABC pascal), которая находит сумму четных цифр

и произведение нечетных чисел
в диапазоне от 1 до 10.

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

народ мне срочно нужно написать программу на языке паскаль

суть программы вычислять по ответам на вопросы (да,нет) есть ли у вас игровая зависимость,
Вопросы:
1 В день вы играете более 2-ух часов?
2 Становитесь ли вы раздражительным после игры?
3 Из-за компьютерной игры вы пренебрегает сном?
4 Для игры в компьютерные игры вы жертвует временем, ранее проводимым с семьёй, друзьями?
5 вы приобретаете проблемы в учёбе, на работе из-за компьютерной игры но продолжаете в неё играть?
6 После компьютерной игры у вас возникает сухость слизистых глаз?
7 Человек испытывает потребность проводить за игрой всё больше времени?
8 Из-за компьютерной игры человек пренебрегает личной гигиеной?
9 Во время компьютерной игры человек полностью отрешается от реальной действительности, переносясь целиком в мир игры




народ кароче если в ответах да повторяется более чем 2 раза то программа должна вывести "есть вероятность что у вас есть игровая зависимость"
если нет то "пока вам не стоит беспокоиться"\



за ранние огромное спасибо



Вы находитесь на странице вопроса "Задано трехзначное число, написать программу на языке Паскаль, которая находит сумму его цифр и проверить четное оно или нет.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.